HDU2147 - kiki's game 【巴什博弈】

Recently kiki has nothing to do. While she is bored, an idea appears in his mind, she just playes the checkerboard game.The size of the chesserboard is n*m.First of all, a coin is placed in the top right corner(1,m). Each time one people can move the coin into the left, the underneath or the left-underneath blank space.The person who can't make a move will lose the game. kiki plays it with ZZ.The game always starts with kiki. If both play perfectly, who will win the game? 

Input

Input contains multiple test cases. Each line contains two integer n, m (0<n,m<=2000). The input is terminated when n=0 and m=0. 
 

Output

If kiki wins the game printf "Wonderful!", else "What a pity!". 

Sample Input

5 3
5 4
6 6
0 0

Sample Output

What a pity!
Wonderful!
Wonderful!

思路:因爲行列分別要走m-1和n-1步,所以要保證至少m和n其中有一個是2的倍數,這樣才能保證贏

#include<cstdio>
 
int main( )
{
    int n,m;
    while(scanf("%d%d",&n,&m)&&(n!=0||m!=0))
    {
        if(n%2==0||m%2==0)
            printf("Wonderful!\n");
        else
            printf("What a pity!\n");
    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章