poj_1064_Cable master(二分搜索,最大最小/最小最大)

Cable master
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 58900 Accepted: 12275

Description

Inhabitants of the Wonderland have decided to hold a regional programming contest. The Judging Committee has volunteered and has promised to organize the most honest contest ever. It was decided to connect computers for the contestants using a "star" topology - i.e. connect them all to a single central hub. To organize a truly honest contest, the Head of the Judging Committee has decreed to place all contestants evenly around the hub on an equal distance from it. 
To buy network cables, the Judging Committee has contacted a local network solutions provider with a request to sell for them a specified number of cables with equal lengths. The Judging Committee wants the cables to be as long as possible to sit contestants as far from each other as possible. 
The Cable Master of the company was assigned to the task. He knows the length of each cable in the stock up to a centimeter,and he can cut them with a centimeter precision being told the length of the pieces he must cut. However, this time, the length is not known and the Cable Master is completely puzzled. 
You are to help the Cable Master, by writing a program that will determine the maximal possible length of a cable piece that can be cut from the cables in the stock, to get the specified number of pieces.

Input

The first line of the input file contains two integer numb ers N and K, separated by a space. N (1 = N = 10000) is the number of cables in the stock, and K (1 = K = 10000) is the number of requested pieces. The first line is followed by N lines with one number per line, that specify the length of each cable in the stock in meters. All cables are at least 1 meter and at most 100 kilometers in length. All lengths in the input file are written with a centimeter precision, with exactly two digits after a decimal point.

Output

Write to the output file the maximal length (in meters) of the pieces that Cable Master may cut from the cables in the stock to get the requested number of pieces. The number must be written with a centimeter precision, with exactly two digits after a decimal point. 
If it is not possible to cut the requested number of pieces each one being at least one centimeter long, then the output file must contain the single number "0.00" (without quotes).

Sample Input

4 11
8.02
7.43
4.57
5.39

Sample Output

2.00

Source

代碼:

c++:

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
#define Max 100005
#define inf 1e9
using namespace std;
int n,k;
double L[Max];
bool search(double x)
{
    int sum = 0;
    for(int i=1;i<=n;i++)
    {
        sum += (int )(L[i]/x);
    }
    return sum >= k;
    /*if(sum >= k)  //繩子總條數大於K
        return 1;
    else
        return 0;*/
}
void solve()
{
    double l = 0;
    double r = inf;
    for(int i=0;i<100;i++)
    {
        double mid = (l+r)/2;
        if(search(mid))
            l = mid;
        else
            r = mid;
    }
    printf("%.2f\n",floor(l*100)/100);
}
int main()
{
    scanf("%d%d",&n,&k);
    for(int i=1;i<=n;i++)
        scanf("%lf",&L[i]);
    solve();

    return 0;
}

Java:

import java.util.*;
import java.math.*;
public class Main {

	public static int Max = 100005;
	public static int inf = 100000;
	public static int k,n;
	public static double L[] = new double[Max];
	//private static Scanner in;
	public static int search(double x) {
		int sum = 0;
		for(int i=1;i<=n;i++)
		{
			sum += (int )(L[i]/x);
		}
		if(sum >= k)
			return 1;
		else
			return 0;
	}
	public static void solve() {
		double left = 0;
		double right = inf;
		for(int i=0;i<100;i++)
		{
			double mid = (left + right)/2;
			if(search(mid) == 1)
				left = mid;
			else
				right = mid;
		}
		System.out.printf("%4.2f",Math.floor(left*100)/100);
	}
	public static void main(String[] args) {
		Scanner in = new Scanner(System.in);
		n = in.nextInt();
		 k = in.nextInt();
		//int []L = new int[Max];
		for(int i=1;i<=n;i++)
			L[i] = in.nextDouble();
		solve();
	}

}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章