poj_3258_River Hopscotch(二分搜索,最下最大問題)

River Hopscotch
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 17792 Accepted: 7437

Description

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to rocks (0 ≤ M ≤ N).

FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

Input

Line 1: Three space-separated integers: LN, and M  Lines 2..N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks

Sample Input

25 5 2
2
14
11
21
17

Sample Output

4

Hint

Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).

Source

題意:

類似題目poj2456在n個牛欄中加入m頭牛;
現在是在n個石頭中取走m個,相當於在n箇中加入n-m個。
原題中說開頭與結尾不變,即第一個爲起始位置0,最後一個爲長度L,
所以數組的第一個爲0,最後一個爲L;其他的都與poj2456相同的思想


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int Max = 50005;
int L,n,m;
int x[Max];
bool C(int k)
{
    int num = 1,cnt = x[0];
    for(int i=1;i<n;i++)
    {
        if(x[i] - cnt >= k)
        {
            num ++;
            cnt = x[i];
        }
        if(num >= n-m)
            return true;
    }
    return false;
}
void solve()
{
    int left = 0,right = L+1;
    while(left < right)
    {
        int mid = (left + right)/2;
        if(C(mid))
            left = mid+1;
        else
            right = mid;
    }
    printf("%d\n",left-1);
}
int main()
{
    scanf("%d%d%d",&L,&n,&m);
    for(int i=1;i<=n;i++)
        scanf("%d",&x[i]);
    n++;
    x[n] = L;
    n++;
    sort(x,x+n);
    solve();
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章