PiggyBank-完全揹包

Piggy-Bank

Problem Description
Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid.

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!

Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams.
 

Output
Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.".
 

Sample Input
3
10 110
2
1 1
30 50
10 110
2
1 1
50 30
1 6
2
10 3
20 4

Sample OutputThe minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.
This is impossible.

源代碼:
#include<stdio.h>
#define INF (1<<30)
#define MAX 10002

int T , N , V , v , pack[MAX];
int value[MAX] , volume[MAX];

int Min( int a , int b ){ return a <= b ? a : b; }
int CompletePack( void );

int main( ){
    int min;
    scanf("%d",&T);

    while( T-- ){
        scanf("%d%d",&v,&V);
        scanf("%d",&N);
        for( int i=0 ; i<N ; i++ )
            scanf("%d%d",&value[i],&volume[i]);
        min = CompletePack();
        if( min==INF )
            printf("This is impossible.\n");
        else
            printf("The minimum amount of money in the piggy-bank is %d.\n",min);
    }

    return 0;
}


int CompletePack( void ){
    V -= v;    //體積爲V-v的揹包

    for( int i=1 ; i<=V ; i++ )    //初始化,注意是i<=V
        pack[i] = INF;    //INF最大值爲(2<<31)-1

    pack[0] = 0;

    for( int i=0 ; i<N ; i++ )
        for( int v=volume[i] ; v<=V ; v++ )    //完全揹包,從小的體積包更新大的體積包
            pack[v] = Min( pack[v] , pack[v-volume[i]]+value[i] );

    return pack[V];
}

代碼分析:題目是一道完全揹包的題,很容易,不過要理解模板,完全揹包要求物品的個數可以爲無數個,所以用體積小的dp值來更新體積大的dp值,體現了物品能夠多次選擇的原則。注意初始化是i<=V,第一次wa了因爲沒寫等號,囧...
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章