Humble Numbers-類DP

Humble Numbers
Source:hdu-1058

Problem Description
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.
Write a program to find and print the nth element in this sequence

Input
The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.

Output
For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.

Sample Input
1
2
3
4
11
12
13
21
22
23
100
1000
5842
0

Sample Output
The 1st humble number is 1.
The 2nd humble number is 2.
The 3rd humble number is 3.
The 4th humble number is 4.
The 11th humble number is 12.
The 12th humble number is 14.
The 13th humble number is 15.
The 21st humble number is 28.
The 22nd humble number is 30.
The 23rd humble number is 32.
The 100th humble number is 450.
The 1000th humble number is 385875.
The 5842nd humble number is 2000000000.

源代碼:
#include<iostream>
#define MAX 2000000000
using namespace std;

int dp[6000];
int min( int a , int b ){ return a <= b ? a : b ; }

int main( ){
    int i , n , r , num2 , num3 , num5 , num7;

    dp[1] = i = 1;
    num2 = num3 = num5 = num7 = 1;

    do {
        dp[++i] = min( min( 2*dp[num2] , 3*dp[num3] ) , min( 5*dp[num5] , 7*dp[num7] ) );
        if( dp[i]==2*dp[num2] ) num2++;
        if( dp[i]==3*dp[num3] ) num3++;
        if( dp[i]==5*dp[num5] ) num5++;
        if( dp[i]==7*dp[num7] ) num7++;
    }while( i<=5842 );

    while( cin>>n && n ){
        r = n / 10 % 10;
        cout<<"The "<<n;
        if( n%10==1 && r!=1 ) cout<<"st ";
        else if( n%10==2 && r!=1 ) cout<<"nd ";
        else if( n%10==3 && r!=1 ) cout<<"rd ";
        else cout<<"th ";
        cout<<"humble number is ";
        cout<<dp[n]<<"."<<endl;
    }

    return 0;
}

代碼分析:其實該算法是以O(n^2)的算法演變而來的,原算法是每求一個dp[n]的值時候,i遍歷1->n-1,尋找dp[i]*2/3/5/7中大於dp[n-1]的最小值.由於範圍只限制在5842,所以O(n^2)應該也能在1000ms內解決.
O(n)的算法如上,比較簡潔,不過確實琢磨了很久才弄懂.優化的地方在於不用遍歷每一個dp[1->n-1],而是有四個位置記錄標誌num2,num3,num5,num7來標誌準備下一個更新的數值值可能是這幾個位置的對應數乘2/3/5/7得來的,沒有具體證明,不過草稿紙寫一下應該就能大致得出該結論,本算法渣認爲想到這個算法的那人確實不容易啊,點贊.
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章