HDU 5573.Binary Tree【二進制 構造】【8月10】

Binary Tree

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 618    Accepted Submission(s): 355
Special Judge


Problem Description
The Old Frog King lives on the root of an infinite tree. According to the law, each node should connect to exactly two nodes on the next level, forming a full binary tree.

Since the king is professional in math, he sets a number to each node. Specifically, the root of the tree, where the King lives, is 1. Say froot=1.

And for each node u, labels as fu, the left child is fu×2 and right child is fu×2+1. The king looks at his tree kingdom, and feels satisfied.

Time flies, and the frog king gets sick. According to the old dark magic, there is a way for the king to live for another N years, only if he could collect exactly Nsoul gems.

Initially the king has zero soul gems, and he is now at the root. He will walk down, choosing left or right child to continue. Each time at node x, the number at the node is fx (remember froot=1), he can choose to increase his number of soul gem by fx, or decrease it by fx.

He will walk from the root, visit exactly K nodes (including the root), and do the increasement or decreasement as told. If at last the number is N, then he will succeed.

Noting as the soul gem is some kind of magic, the number of soul gems the king has could be negative.

Given NK, help the King find a way to collect exactly N soul gems by visiting exactly K nodes.
 

Input
First line contains an integer T, which indicates the number of test cases.

Every test case contains two integers N and K, which indicates soul gems the frog king want to collect and number of nodes he can visit.

 1T100.

 1N109.

 N2K260.
 

Output
For every test case, you should output "Case #x:" first, where x indicates the case number and counts from 1.

Then K lines follows, each line is formated as 'a b', where a is node label of the node the frog visited, and b is either '+' or '-' which means he increases / decreases his number by a.

It's guaranteed that there are at least one solution and if there are more than one solutions, you can output any of them.

 

Sample Input
2 5 3 10 4
 

Sample Output
Case #1: 1 + 3 - 7 + Case #2: 1 + 3 + 6 - 12 +
 
Special Judge
因此不需要看他的樣例怎麼來的,只需要找到一種能夠把數字構造出來的方法。
首先1.2.4.8......2^n可以構造出1~2^(n+1)所有的數。1.2.4.8......2^n的和爲2^(n+1) 如果需要構造N(偶數),則有2^(n+1)-N是多餘的,則需要構造一個負的(2^(n+1)-N)/2。
如樣例1,.2^n=8,因爲5是奇數,則用2^n-1做,7-5=2;2/2=1; 即構造一個-1,選擇1的地方爲-號就行了,即-1 + 2 + 4;
1二進制 爲  000001, 即構造的時候1的位置選-號,0的位置選+號。
#include<iostream>
#include<cstdio>
using namespace std;
int T, kase = 1;
long long N, K;
int main()
{
    scanf("%d", &T);
    while(T--)
    {
        scanf("%lld %lld", &N, &K);
        printf("Case #%d:\n", kase++);
        long long sum = 0, num = 1;
        for(int i = 1;i < K; ++i)
        {
            sum += num;
            num *= 2;
        }
        if(N%2 == 0) sum += (num+1);
        else sum += num;
        long long d = (sum-N)/2;
        num = 1;
        while(K-- > 1)
        {
            cout << num <<" ";
            if(d%2 == 0) cout <<"+"<< endl;
            else cout <<"-"<< endl;
            d /= 2;
            num *= 2;
        }
        if(N%2 == 0) cout << num+1 <<" ";
        else cout << num <<" ";
        if(d%2 == 0) cout <<"+"<< endl;
        else cout <<"-"<< endl;
    }
    return 0;
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章