Codeforces Round #315 (Div. 2)

Description

Little Lesha loves listening to music via his smartphone. But the smartphone doesn't have much memory, so Lesha listens to his favorite songs in a well-known social network InTalk.

Unfortunately, internet is not that fast in the city of Ekaterinozavodsk and the song takes a lot of time to download. But Lesha is quite impatient. The song's duration is T seconds. Lesha downloads the first S seconds of the song and plays it. When the playback reaches the point that has not yet been downloaded, Lesha immediately plays the song from the start (the loaded part of the song stays in his phone, and the download is continued from the same place), and it happens until the song is downloaded completely and Lesha listens to it to the end. For q seconds of real time the Internet allows you to download q - 1 seconds of the track.

Tell Lesha, for how many times he will start the song, including the very first start.

Input

The single line contains three integers T, S, q (2 ≤ q ≤ 104, 1 ≤ S < T ≤ 105).

Output

Print a single integer — the number of times the song will be restarted.

Sample Input

Input
5 2 2
Output
2
Input
5 4 7
Output
1
Input
6 2 3
Output
1

Sample Output

Case 1: 62.5000000000

Case 2: 150

Hint

In the first test, the song is played twice faster than it is downloaded, which means that during four first seconds Lesha reaches the moment that has not been downloaded, and starts the song again. After another two seconds, the song is downloaded completely, and thus, Lesha starts the song twice.

In the second test, the song is almost downloaded, and Lesha will start it only once.

In the third sample test the download finishes and Lesha finishes listening at the same moment. Note that song isn't restarted in this case.


目大意:一個人下載歌,每q個時間單位能下載q-1個時間單位的歌,歌的長度爲T,下到S的時候開始播放,如果歌還沒下完且放到了還未下載的地方,則重頭開始放,問一共要放多少次

題目分析:一開始從s開始,設下了x秒後聽和下的進度相同,則 s + (q - 1) / q * x = x,解得x= q * s,然後從頭開始,設t'秒後進度相同,則(q - 1) / q * t' + x= t',解得t' = x * q,可見直接拿第一次進度相同的時間乘q就是接下來每次進度相同的.

代碼:

#include<cstdio>
using namespace std;
int main()
{
    int T,S,q,x,ans;
   while(scanf("%d%d%d",&T,&S,&q)!=EOF)
   {

        ans=1;
        x=q*S;
        while(x<T)
        {
            x=q*x;
            ans++;
        }
        printf("%d\n",ans);
   }

    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章