B-number(HDU-3652)

Problem Description

A wqb-number, or B-number for short, is a non-negative integer whose decimal form contains the sub- string "13" and can be divided by 13. For example, 130 and 2613 are wqb-numbers, but 143 and 2639 are not. Your task is to calculate how many wqb-numbers from 1 to n for a given integer n.

Input 

Process till EOF. In each line, there is one positive integer n(1 <= n <= 1000000000).

Output

Print each answer in a single line.

Sample Input

13 100 200 1000

Sample Output

1 1 2 2

————————————————————————————————————————————————————

題意:給一個數 n,求 1~n 中有多少數 x 符合 x%13==0 且 x 中出現過 “13” 這個子串

思路:開三維數組,分別表示位數、mod、狀態,數位DP即可

每次注意保留 sta 的狀態:用 0 表示當前枚舉的前一位不是 1,1 表示前一位是 1,2 表示之前枚舉的數位裏已有 13  

Source Program

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<string>
#include<cstdlib>
#include<queue>
#include<set>
#include<map>
#include<stack>
#include<ctime>
#include<vector>
#define INF 0x3f3f3f3f
#define PI acos(-1.0)
#define N 31
#define MOD 10007
#define E 1e-6
typedef long long LL;
using namespace std;
int bit[N];
int dp[N][N][N];
int dfs(int pos,int mod,int sta,bool limit)
{
    if(pos<1)
        return sta==2&&mod==0;
    if(!limit && dp[pos][mod][sta]!=-1)
        return dp[pos][mod][sta];

    int temp=0;
    int up=limit?bit[pos]:9;
    for(int i=0;i<=up;i++)
    {
        int sta_temp=sta;
        int mod_temp=(mod*10+i)%13;
        if(sta==0&&i==1)
            sta_temp=1;
        if(sta==1&&i!=1)
            sta_temp=0;
        if(sta==1&&i==3)
            sta_temp=2;

        temp+=dfs(pos-1,mod_temp,sta_temp,limit&&i==up);
    }

    if(!limit)
        dp[pos][mod][sta]=temp;
    return temp;
}
int solve(int x)
{
    int pos=1;
    while(x)
    {
        bit[pos++]=x%10;
        x/=10;
    }
    return dfs(pos,0,0,true);
}
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        memset(dp,-1,sizeof(dp));
        printf("%d\n",solve(n));
    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章