Balanced Number(HDU-3709)

Problem Description

A balanced number is a non-negative integer that can be balanced if a pivot is placed at some digit. More specifically, imagine each digit as a box with weight indicated by the digit. When a pivot is placed at some digit of the number, the distance from a digit to the pivot is the offset between it and the pivot. Then the torques of left part and right part can be calculated. It is balanced if they are the same. A balanced number must be balanced with the pivot at some of its digits. For example, 4139 is a balanced number with pivot fixed at 3. The torqueses are 4*2 + 1*1 = 9 and 9*1 = 9, for left part and right part, respectively. It's your job
to calculate the number of balanced numbers in a given range [x, y].

Input 

The input contains multiple test cases. The first line is the total number of cases T (0 < T ≤ 30). For each case, there are two integers separated by a space in a line, x and y. (0 ≤ x ≤ y ≤ 1018).

Output

For each case, print the number of balanced numbers in the range [x, y] in a line.

Sample Input

2
0 9
37604 24324

Sample Output

10
897

————————————————————————————————————————————————————

題意:給出區間 [l,r] 內平衡數的個數,平衡數是指,以某位作爲支點,此位左邊的 數字*距離 的和與右邊相等 

思路:以 dp[pos][x][sta] 代表第pos位的數支點是x,目前力矩爲sta的數的個數,對於每一位,以此位爲支點計算力矩,然後判斷這個數是否爲平衡數

Source Program

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<string>
#include<cstdlib>
#include<queue>
#include<set>
#include<map>
#include<stack>
#include<ctime>
#include<vector>
#define INF 0x3f3f3f3f
#define PI acos(-1.0)
#define N 21
#define MOD 10007
#define E 1e-6
typedef long long LL;
using namespace std;
int bit[N];
LL dp[N][N][N*100];
LL dfs(int pos,int x,int sta,bool limit)
{
    if(pos<=0)
        return sta==0;
    if(sta<0)
        return 0;
    if(!limit&&dp[pos][x][sta]!=-1)
        return dp[pos][x][sta];

    int res=0;
    int up=limit?bit[pos]:9;
    for(int i=0;i<=up;i++)
    {
        int next=sta+i*(pos-x);
        res+=dfs(pos-1,x,next,limit&&(i==up));
    }
    if(!limit)
        dp[pos][x][sta]=res;

    return res;
}
LL solve(LL x)
{
    int len=0;
    while(x)
    {
        bit[++len]=x%10;
        x/=10;
    }

    LL sum=0;
    for(int i=1;i<=len;i++){
        sum+=dfs(len,i,0,true);
    }
    return sum-(len-1);//減去 00、000 、0000...的情況
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        LL left,right;
        scanf("%lld%lld",&left,&right);

        memset(dp,-1,sizeof(dp));
        printf("%lld\n",solve(right)-solve(left-1));
    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章