RIP路由協議實驗

任務一

clip_image002

1 R1,R2,R3配置好rip V1 觀察不連續子網的產生的後果,

在R2上ping 10.1.1.0/24網段的IP,觀察結果如何?

2接下來配置好rip v2 讓10.1.1.0/24網段與10.1.2.0/24網段能互相ping通

使用debug ip rip 來觀察rip v1和rip v2的更新報文

任務二

clip_image004

1配置A,B,C的rip v2

v 實現10.1.1.2、10.1.2.2和192.168.2.2三臺主機能夠互相通信(提示:水平分割)

2當全網互通後,在A上使用passive-int 命令,讓A不發送路由更新給B,C;

任務三:

自己設計一個拓樸,測試浮動靜態路由

image

實驗步驟:【必寫】

分類寫出你的實驗進行中的步驟,可用文字或圖片加水印標記

1.

任務一思路:

對於路由器:

1:命名

2:設置端口IP

3:設置RIPv1版本

4:設置RIPv2版本

查看命令:

查看基本配置命令:

show running-config

查看路由信息:

show ip route

查看路由協議:

show ip protocol

配置文檔:

R1

enable

config terminal

no ip domain-lookup

hostname R1

interface loop 0

ip address 10.1.1.1 255.255.255.0 //設置IP

no shutdown

interface f0/0

ip address 192.168.1.1 255.255.255.0 //設置IP

no shutdown

exit

router rip //設置RIP版本

network 10.1.1.0

network 192.168.1.0

end

write

config terminal

router rip //設置RIPv2版本

network 10.1.1.0

network 192.168.1.0

version 2

no auto-summary

end

write

R2

enable

config terminal

no ip domain-lookup

hostname R2

interface f1/0

ip address 192.168.1.2 255.255.255.0 //設置IP

no shutdown

interface f0/0

ip address 192.168.2.1 255.255.255.0 //設置IP

no shutdown

exit

router rip //設置RIP版本

network 192.168.1.0

network 192.168.2.0

end

write

config terminal

router rip //設置RIPv2版本

network 192.168.2.0

network 192.168.1.0

version 2

no auto-summary

end

write

R3

enable

config terminal

no ip domain-lookup

hostname R3

interface loop 0

ip address 10.1.2.1 255.255.255.0 //設置IP

no shutdown

interface f0/0

ip address 192.168.2.2 255.255.255.0 //設置IP

no shutdown

exit

router rip 、//設置RIP版本

network 10.1.2.0

network 192.168.1.0

end

write

config terminal

router rip //設置RIPv2版本

network 10.1.2.0

network 192.168.2.0

version 2

no auto-summary

end

write

調試截圖 :

clip_image002[4]

clip_image004[4]clip_image006clip_image008clip_image010clip_image012clip_image014clip_image016

2:

思路:

1:對於路由器:

1:命名

2:設置端口IP

3:設置RIPv2版本

對於PC:

1:命名

2:禁用路由功能

3:設置ip

查看命令:

查看基本配置:

show running-config

查看版本信息:

show ip route

查看路由協議信息:

show ip protocol

R1

enable

config terminal

no ip domain-lookup

hostname R1

interface f0/0

ip address 10.1.1.1 255.255.255.0 //設置IP

no shutdown

interface f1/0

ip address 192.168.1.1 255.255.255.0 //設置IP

no shutdown

exit

router rip //設置RIP版本

network 10.1.1.0

network 192.168.1.0

version 2

no auto-summary

end

write

R2

enable

config terminal

no ip domain-lookup

hostname R2

interface f0/0

ip address 10.1.2.1 255.255.255.0 //設置IP

no shutdown

interface f1/0

ip address 192.168.1.2 255.255.255.0 //設置IP

no shutdown

exit

router rip //設置RIP版本

network 10.1.2.0

network 192.168.1.0

version 2

no auto-summary

end

write

R3

enable

config terminal

no ip domain-lookup

hostname R3

interface f0/0

ip address 192.168.1.3 255.255.255.0 //設置IP

no shutdown

interface f1/0

ip address 192.168.2.1 255.255.255.0 //設置IP

no shutdown

exit

router rip //設置RIP版本

network 192.168.1.0

network 192.168.2.0

version 2

no auto-summary

end

write

PC1:

enable

config terminal

no ip routing

hostname pc1

interface f0/0

ip address 10.1.1.2 255.255.255.0 //設置IP

no shutdown

end

write

PC2:

enable

config terminal

no ip routing

hostname pc2

interface f0/0

ip address 10.1.2.2 255.255.255.0 //設置IP

no shutdown

end

write

PC3:

enable

config terminal

no ip routing

hostname pc3

interface f0/0

ip address 192.168.2.2 255.255.255.0 //設置IP

no shutdown

end

write

測試截圖:

clip_image018

3:

對於路由器:

1:命名

2:設置端口IP

3:設置靜態路由

查看命令:

查看基本配置命令:

show running-config

查看路由信息:

show ip route

查看路由協議:

show ip protocol

---------------------------------------

配置文檔:

R1

enable

config terminal

no ip domain-lookup

hostname R1

interface loop 0

ip address 10.1.1.1 255.255.255.0 //設置IP

no shutdown

interface f0/0

ip address 192.168.1.1 255.255.255.0 //設置IP

no shutdown

exit

ip route 10.1.2.0 255.255.255.0 192.168.1.2 //設置靜態路由

ip route 192.168.2.0 255.255.255.0 192.168.1.2

end

write

R2

enable

config terminal

no ip domain-lookup

hostname R2

interface f1/0

ip address 192.168.1.2 255.255.255.0 //設置IP

no shutdown

interface f0/0

ip address 192.168.2.1 255.255.255.0 //設置IP

no shutdown

exit

ip route 10.1.1.0 255.255.255.0 192.168.1.1 //設置靜態路由

ip route 10.1.2.0 255.255.255.0 192.168.2.2

end

write

R3

enable

config terminal

no ip domain-lookup

hostname R3

interface loop 0

ip address 10.1.2.1 255.255.255.0 //設置IP

no shutdown

interface f0/0

ip address 192.168.2.2 255.255.255.0 //設置IP

no shutdown

exit

ip route 10.1.1.0 255.255.255.0 192.168.2.1 //設置靜態路由

ip route 192.168.1.0 255.255.255.0 192.168.2.1

end

write

測試截圖:

clip_image020clip_image022

實驗結論及排除思路或命令:【必寫】

1. 寫出通過本次上機實驗操作,你得出了什麼樣的結論

任務一:動態路由宣告的是網絡段,就是v1、v2版本在調試的時候一個是攜帶子網掩碼,另外一個是不攜帶子網掩碼,造成的問題是,如果都是同一個網段,比方說上面第一個實例,如果是10.1.1.0/24,和10.1.2.0/24這2個網段的話,v1版本會讓這2個網段歸屬到10.0.0.0/8這個網絡段去。。。 這個就是V1版本的問題。。。導致2個網段不能連通。

任務二:

這裏3路由是通過交換機來連接的,

交換機的接口不需要開通,只要連接了就能夠

自動開通。。。。而路由器必須設置成no shutdown,。

任務三:

浮動路由的原理,就是把一個網段斷開,看其它路由器工作原理,

並查看路由器信息(show ip route),就會出現浮動。

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章