1989: Julyed(水)

Time Limit: 2 Sec  Memory Limit: 64 MB
Submit: 30  Solved: 28

Description

Julyed is preparing for her CET-6. She has N words to remember, but there is only M days left. If she can’t remember all these words, she won’t pass CET-6. If she can’t pass CET-6, she will be unhappy. But if she remember too many words in one day, she will be unhappy, too. If she is unhappy, tomriddly will be unhappy. So she will remember as little words as she can in one day. For the happiness of both tomriddly and Julyed, how many words at most will Julyed remember in one day?

Input

Multiple test cases. The first line is an integer T (T <= 10000), indicating the number of test cases.
Each test case is a line with two integers N, M (1 <= N, M <= 200), indicating the number of words to remember and the number of days left.
 

Output

One line per case, an integer indicates the answer.

Sample Input

5 6 3 2 1 1 2 5 2 4 3

Sample Output

2 2 1 3 2

HINT

 

Source

題意:確認過題意,是道水題

代碼:

#include<iostream>
using namespace std;
int main()
{
    int t;
    while(cin>>t)
    {
        while(t--)
        {
            int n,m;
            cin>>n>>m;
            if(n<m)
                cout<<"1"<<endl;
            else
            {
                if(n%m==0)
                    cout<<n/m<<endl;
                else
                    cout<<n/m+1<<endl;
            }
        }

    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章