JAVA語言1031 Hello World for U (20 分)

1031 Hello World for U (20 分)

Given any string of N (≥5) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n​1​​ characters, then left to right along the bottom line with n​2​​characters, and finally bottom-up along the vertical line with n​3​​ characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n​1​​=n​3​​=max { k | k≤n​2​​ for all 3≤n​2​​≤N } with n​1​​+n​2​​+n​3​​−2=N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h   !
e   d
l   l
lowor

 

一個特別一點的解法:

import java.util.Scanner;

import javax.xml.stream.events.StartDocument;

public class Main {

	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner sc=new Scanner(System.in);
		String str=sc.nextLine();
		char[][]a=new char[30][30];
		int n=(str.length()+2)/3;
		int y=str.length()+2-n-n;
//		System.out.println(n);
//		System.out.println(y);
		for(int i=0;i<n-1;i++){
			System.out.print(str.charAt(i));
			for(int j=0;j<y-2;j++){
				System.out.print(" ");
			}
			System.out.println(str.charAt(str.length()-1-i));
		}
		for(int i=n-1;i<n-1+y;i++){
			System.out.print(str.charAt(i));
		}
		//System.out.println(a[0][2]);
	}
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章