hdu 2795

At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information. 

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard. 

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi. 

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one. 

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university). 

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.

 

Input

There are multiple cases (no more than 40 cases). 

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements. 

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.

 

Output

For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.

 

Sample Input


 

3 5 5 2 4 3 3 3

 

Sample Output


 

1 2 1 3 -1

我們可以對(1~h)區間進行區間化,每個節點記錄當前區間內剩餘可放空間的最大值。我們遍歷時先遍歷左子樹,再右子樹。

左子樹 表示小行。

模型建好了,就是個裸的線段樹

 

#include <queue>
#include <cstdio>
#include <set>
#include <string>
#include <stack>
#include <cmath>
#include <climits>
#include <map>
#include <cstdlib>
#include <iostream>
#include <vector>
#include <algorithm>
#include <cstring>
#include <stdio.h>
#include <ctype.h>
#include <bitset>
#define  LL long long
#define  ULL unsigned long long
#define mod 10007
#define INF 0x7ffffff
#define mem(a,b) memset(a,b,sizeof(a))
#define MODD(a,b) (((a%b)+b)%b)
using namespace std;
const int maxn = 3e6 + 5;
int h,n;
struct node
{
    int l;
    int r,Max;
}T[maxn << 2];
void pushUp(int rt)
{
    T[rt].Max = max(T[rt << 1].Max,T[rt << 1 | 1].Max);
}
void buildTree(int l,int r,int rt,int w)
{
    T[rt].l = l;
    T[rt].r = r;
    T[rt].Max = w;
    if(l == r) return;
    int mid = (l + r) >> 1;
    buildTree(l,mid,rt << 1,w);
    buildTree(mid + 1,r,rt << 1 | 1,w);
}
void upDate(int rt,int kk)
{
    if(T[rt].l == T[rt].r){
      printf("%d\n",T[rt].l);
      T[rt].Max -= kk;
      return ;
    }
    if(kk <= T[rt << 1].Max) upDate(rt << 1,kk);
    else upDate(rt << 1 | 1,kk);
    pushUp(rt);
}
int main()
{
    int h,w,n;
    while(~scanf("%d%d%d",&h,&w,&n)){
        if(h > n) h = n;
        buildTree(1,h,1,w);
        for(int i = 0; i < n; i++){
          int x;
          scanf("%d",&x);
          if(T[1].Max < x) printf("-1\n");
          else upDate(1,x);
        }

    }





    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章