PAT 1147

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

Your job is to tell if a given complete binary tree is a heap.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 100), the number of trees to be tested; and N (1 < N ≤ 1,000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all. Then in the next line print the tree's postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.

Sample Input:

3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56

Sample Output:

Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10
#include <iostream>
#include <vector>

using namespace std;
int array[1005];
int N;
int judge(){
    bool a= true;
    bool b= true;
    for (int i = N/2-1; i >=0 ; --i) {
        if(2*i+1<N){
            a=a&(array[i]<=array[2*i+1]);
            b=b&(array[i]>=array[2*i+1]);
        }
        if(2*i+2<N){
            b=b&(array[i]>=array[2*i+2]);
            a=a&(array[i]<=array[2*i+2]);
        }
    }
    if(a){
        return 0;
    }
    if(b){
        return 1;
    }
    return -1;
}
bool first;
void postorder(int i){
    if(i>=N){
        return;
    }
    postorder(2*i+1);
    postorder(2*i+2);
    if(first){
        cout<<array[i];
        first= false;
    } else{
        cout<<" "<<array[i];
    }
}
int main() {
    int M;
    cin>>M>>N;
    for (int i = 0; i <  M; ++i) {
        for (int j = 0; j < N; ++j) {
            cin>>array[j];
        }
        int res=judge();
        if(res==1){
            cout<<"Max Heap"<<endl;
        }else if(res==0){
            cout<<"Min Heap"<<endl;
        } else{
            cout<<"Not Heap"<<endl;
        }
        first= true;
        postorder(0);
        cout<<endl;
    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章