POJ 2063 —— Investment【完全揹包】

題目傳送門

求投資k年獲得最大投資,每年都選最大利息的方案進行投資k年後就可以得到最多的人民幣。


Description

John never knew he had a grand-uncle, until he received the notary’s letter. He learned that his late grand-uncle had gathered a lot of money, somewhere in South-America, and that John was the only inheritor.
John did not need that much money for the moment. But he realized that it would be a good idea to store this capital in a safe place, and have it grow until he decided to retire. The bank convinced him that a certain kind of bond was interesting for him.
This kind of bond has a fixed value, and gives a fixed amount of yearly interest, payed to the owner at the end of each year. The bond has no fixed term. Bonds are available in different sizes. The larger ones usually give a better interest. Soon John realized that the optimal set of bonds to buy was not trivial to figure out. Moreover, after a few years his capital would have grown, and the schedule had to be re-evaluated.
Assume the following bonds are available:
在這裏插入圖片描述
With a capital of e10 000 one could buy two bonds of $4 000, giving a yearly interest of $800. Buying two bonds of $3 000, and one of $4 000 is a better idea, as it gives a yearly interest of $900. After two years the capital has grown to $11 800, and it makes sense to sell a $3 000 one and buy a $4 000 one, so the annual interest grows to $1 050. This is where this story grows unlikely: the bank does not charge for buying and selling bonds. Next year the total sum is $12 850, which allows for three times $4 000, giving a yearly interest of $1 200.
Here is your problem: given an amount to begin with, a number of years, and a set of bonds with their values and interests, find out how big the amount may grow in the given period, using the best schedule for buying and selling bonds.


Input

The first line contains a single positive integer N which is the number of test cases. The test cases follow.
The first line of a test case contains two positive integers: the amount to start with (at most $1 000 000), and the number of years the capital may grow (at most 40).
The following line contains a single number: the number d (1 <= d <= 10) of available bonds.
The next d lines each contain the description of a bond. The description of a bond consists of two positive integers: the value of the bond, and the yearly interest for that bond. The value of a bond is always a multiple of $1 000. The interest of a bond is never more than 10% of its value.


Output

For each test case, output – on a separate line – the capital at the end of the period, after an optimal schedule of buying and selling.


Sample Input

1
10000 4
2
4000 400
3000 250


Sample Output

14050


題意:

給你錢數,還有年數year,還有多少錢一年多少利息,問幾年後最多的錢數(利息算到下一年的本金中)。


分析:

  • 求year次完全揹包
  • 注意因爲投資的錢都是1000的倍數,所以可以÷1000縮小揹包數

內存問題:

注意題目中的本金很大但是最開始最多的本金不超過$1 000 000,而且每種計算利息所需的本金都是$1 000的倍數,所以爲了避免超內存,每次dp時先把本金除以$1 000,相應的cost也除以$1 000。那麼dp數組到底開多大才合適呢,題中說最多存40年,開始時本金不超過$1 000 000而每次的利息又不會超過本金的 10% ,所以 數組的大小應該是 $1 000 000 / 1000 * ( 1.1 ) 40而 1.140 大概爲 45.259256,就取 50 吧。從而數組開 1 000 * 50 = 50 000


AC代碼:

#include <iostream>
#include <vector>
#include <utility>
#include <cstring>
#include <algorithm>
#include <map>
#include <queue>
#include <stack>
#include <cstdio>
#include <fstream>
#include <set>
using namespace std;
typedef long long ll;
#define ios ios::sync_with_stdio(false);cin.tie(0);cout.tie(0);

const int MAXN = 1e6;
#define INF 0x3f3f3f


ll dp[MAXN];
ll w[MAXN];
ll v[MAXN];

int main() {

	int T;
	while (cin >> T) {
		while (T--) {
			memset(dp, 0, sizeof dp);
			int V, year;
			cin >> V >> year;
			int n;
			cin >> n;
			for (int i = 1; i <= n; i++) {
				cin >> w[i] >> v[i];
				w[i] /= 1000;
			}
			while (year--) {
				int tmp = V / 1000;
				for (int i = 1; i <= n; i++) {
					for (int j =0; j <= tmp; j++) {
						if (j >= w[i])
							dp[j] = max(dp[j], dp[j - w[i]] + v[i]);
					}
				}
				V += dp[tmp];

			}
			cout << V << endl;
		}
	}

	return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章