華爲綜合實驗——單臂、三層交換、動靜路由、VRRP路由、DHCP中繼、捆綁Etrunk

實驗圖:

目的:實現pc1、2、5、6的數據互相傳輸
華爲綜合實驗——單臂、三層交換、動靜路由、VRRP路由、DHCP中繼、捆綁Etrunk

跟我一起,盤它

LSW3

#
sysname SW3
#
vlan batch 10 20
#
lacp priority 1000
#
cluster enable
ntdp enable
ndp enable
#
drop illegal-mac alarm
#
diffserv domain default
#
drop-profile default
#
aaa
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default
 domain default_admin
 local-user admin password simple admin
 local-user admin service-type http
#
interface Vlanif1
#
interface MEth0/0/1
#
interface Eth-Trunk1
 port link-type trunk
 port trunk allow-pass vlan 10 20
#
interface Eth-Trunk2
 port link-type trunk
 port trunk allow-pass vlan 10 20
#
interface Ethernet0/0/1
 eth-trunk 1
#
interface Ethernet0/0/2
 eth-trunk 1
#
interface Ethernet0/0/3
 eth-trunk 2
#
interface Ethernet0/0/4
 eth-trunk 2
#
interface Ethernet0/0/5
 port link-type access
 port default vlan 10
#
interface Ethernet0/0/6
 port link-type access
 port default vlan 20

LSW4

#
sysname SW4
#
vlan batch 30 40
#
cluster enable
ntdp enable
ndp enable
#
drop illegal-mac alarm
#
diffserv domain default
#
drop-profile default
#
aaa
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default
 domain default_admin
 local-user admin password simple admin
 local-user admin service-type http
#
interface Vlanif1
#
interface MEth0/0/1
#
interface Eth-Trunk1
 port link-type trunk
 port trunk allow-pass vlan 30 40
#
interface Eth-Trunk2
 port link-type trunk
 port trunk allow-pass vlan 30 40
#
interface Ethernet0/0/1
 eth-trunk 1
#
interface Ethernet0/0/2
 eth-trunk 1
#
interface Ethernet0/0/3
 eth-trunk 2
#
interface Ethernet0/0/4
 eth-trunk 2
#
interface Ethernet0/0/5
 port link-type access
 port default vlan 30
#
interface Ethernet0/0/6
 port link-type access
 port default vlan 40

LSW1

#
sysname SW1
#
vlan batch 10 20 30 40 50
#
cluster enable
ntdp enable
ndp enable
#
drop illegal-mac alarm
#
diffserv domain default
#
drop-profile default
#
aaa
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default
 domain default_admin
 local-user admin password simple admin
 local-user admin service-type http
#
interface Vlanif1
#
interface Vlanif10
 ip address 192.168.10.2 255.255.255.0
 vrrp vrid 1 virtual-ip 192.168.10.1
 vrrp vrid 1 priority 120
 vrrp vrid 1 track interface Eth-Trunk1
 vrrp vrid 1 track interface Eth-Trunk3
#
interface Vlanif20
 ip address 192.168.20.2 255.255.255.0
 vrrp vrid 2 virtual-ip 192.168.20.1
 vrrp vrid 2 priority 115
#
interface Vlanif30
 ip address 192.168.30.2 255.255.255.0
 vrrp vrid 3 virtual-ip 192.168.30.1
 vrrp vrid 3 priority 120
 vrrp vrid 3 track interface Eth-Trunk2
 vrrp vrid 3 track interface Eth-Trunk3
#
interface Vlanif40
 ip address 192.168.40.2 255.255.255.0
 vrrp vrid 4 virtual-ip 192.168.40.1
 vrrp vrid 4 priority 115
#
interface Vlanif50
 ip address 13.0.0.2 255.255.255.0
#
interface MEth0/0/1
#
interface Eth-Trunk1
 port link-type trunk
 port trunk allow-pass vlan 10 20
#
interface Eth-Trunk2
 port link-type trunk
 port trunk allow-pass vlan 30 40
#
interface Eth-Trunk3
 port link-type access
 port default vlan 50
#
interface GigabitEthernet0/0/1
 eth-trunk 1
#
interface GigabitEthernet0/0/2
 eth-trunk 1
#
interface GigabitEthernet0/0/3
 eth-trunk 2
#
interface GigabitEthernet0/0/4
 eth-trunk 2
#
interface GigabitEthernet0/0/5
 eth-trunk 3
#
interface GigabitEthernet0/0/6
 eth-trunk 3
#
interface GigabitEthernet0/0/8
#
interface GigabitEthernet0/0/9
#
interface GigabitEthernet0/0/10
#
interface GigabitEthernet0/0/11
#
interface GigabitEthernet0/0/12
#
interface GigabitEthernet0/0/13
#
interface GigabitEthernet0/0/14
#
interface GigabitEthernet0/0/15
#
interface GigabitEthernet0/0/16
#
interface GigabitEthernet0/0/17
#
interface GigabitEthernet0/0/18
#
interface GigabitEthernet0/0/19
#
interface GigabitEthernet0/0/20
#
interface GigabitEthernet0/0/21
#
interface GigabitEthernet0/0/22
#
interface GigabitEthernet0/0/23
#
interface GigabitEthernet0/0/24
#
interface NULL0
#
ip route-static 0.0.0.0 0.0.0.0 13.0.0.1
#

LSW2

#
sysname SW2
#
vlan batch 10 20 30 40 50
#
cluster enable
ntdp enable
ndp enable
#
drop illegal-mac alarm
#
diffserv domain default
#
drop-profile default
#
aaa
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default
 domain default_admin
 local-user admin password simple admin
 local-user admin service-type http
#
interface Vlanif1
#
interface Vlanif10
 ip address 192.168.10.3 255.255.255.0
 vrrp vrid 1 virtual-ip 192.168.10.1
 vrrp vrid 1 priority 115
#
interface Vlanif20
 ip address 192.168.20.3 255.255.255.0
 vrrp vrid 2 virtual-ip 192.168.20.1
 vrrp vrid 2 priority 120
 vrrp vrid 2 track interface Eth-Trunk2
 vrrp vrid 2 track interface Eth-Trunk3
#
interface Vlanif30
 ip address 192.168.30.3 255.255.255.0
 vrrp vrid 3 virtual-ip 192.168.30.1
 vrrp vrid 3 priority 115
#
interface Vlanif40
 ip address 192.168.40.3 255.255.255.0
 vrrp vrid 4 virtual-ip 192.168.40.1
 vrrp vrid 4 priority 120
 vrrp vrid 4 track interface Eth-Trunk3
 vrrp vrid 4 track interface Eth-Trunk1
#
interface Vlanif50
 ip address 12.0.0.2 255.255.255.0
#
interface MEth0/0/1
#
interface Eth-Trunk1
 port link-type trunk
 port trunk allow-pass vlan 30 40
#
interface Eth-Trunk2
 port link-type trunk
 port trunk allow-pass vlan 10 20
#
interface Eth-Trunk3
 port link-type access
 port default vlan 50
#
interface GigabitEthernet0/0/1
 eth-trunk 1
#
interface GigabitEthernet0/0/2
 eth-trunk 1
#
interface GigabitEthernet0/0/3
 eth-trunk 2
#
interface GigabitEthernet0/0/4
 eth-trunk 2
#
interface GigabitEthernet0/0/5
 eth-trunk 3
#
interface GigabitEthernet0/0/6
 eth-trunk 3
#
interface GigabitEthernet0/0/7
#
interface GigabitEthernet0/0/8
#
interface GigabitEthernet0/0/9
#
interface GigabitEthernet0/0/10
#
interface GigabitEthernet0/0/11
#
interface GigabitEthernet0/0/12
#
interface GigabitEthernet0/0/13
#
interface GigabitEthernet0/0/14
#
interface GigabitEthernet0/0/15
#
interface GigabitEthernet0/0/16
#
interface GigabitEthernet0/0/17
#
interface GigabitEthernet0/0/18
#
interface GigabitEthernet0/0/19
#
interface GigabitEthernet0/0/20
#
interface GigabitEthernet0/0/21
#
interface GigabitEthernet0/0/22
#
interface GigabitEthernet0/0/23
#
interface GigabitEthernet0/0/24
#
interface NULL0
#
ip route-static 0.0.0.0 0.0.0.0 12.0.0.1
#

R1

#
sysname R1
#
aaa
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default
 domain default_admin
 local-user admin password cipher +(V`[email protected]`WtC3IF$':[285RM1#
 local-user admin service-type http
#
firewall zone Local
 priority 16
#
interface Eth-Trunk3
 ip address 13.0.0.1 255.255.255.0
#
interface Eth-Trunk4
 ip address 12.0.0.1 255.255.255.0
#
interface Ethernet0/0/0
#
interface Ethernet0/0/1
#
interface Serial0/0/0
 link-protocol ppp
 ip address 11.0.0.1 255.255.255.252
#
interface Serial0/0/1
 link-protocol ppp
#
interface Serial0/0/2
 link-protocol ppp
#
interface Serial0/0/3
 link-protocol ppp
#
interface GigabitEthernet0/0/0
 eth-trunk 3
#
interface GigabitEthernet0/0/1
 eth-trunk 3
#
interface GigabitEthernet0/0/2
 eth-trunk 4
#
interface GigabitEthernet0/0/3
 eth-trunk 4
#
wlan
#
interface NULL0
#
ip route-static 0.0.0.0 0.0.0.0 11.0.0.2
ip route-static 192.168.10.0 255.255.255.0 13.0.0.2
ip route-static 192.168.10.0 255.255.255.0 12.0.0.2 preference 70
ip route-static 192.168.20.0 255.255.255.0 13.0.0.2 preference 70
ip route-static 192.168.20.0 255.255.255.0 12.0.0.2
ip route-static 192.168.30.0 255.255.255.0 13.0.0.2
ip route-static 192.168.30.0 255.255.255.0 12.0.0.2 preference 70
ip route-static 192.168.40.0 255.255.255.0 13.0.0.2 preference 70
ip route-static 192.168.40.0 255.255.255.0 12.0.0.2
#

R2

#
sysname R2
#
dhcp enable
#
aaa
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default
 domain default_admin
 local-user admin password cipher +(V`[email protected]`WtC:z9:%F`[a=6M4#
 local-user admin service-type http
#
firewall zone Local
 priority 16
#
interface Ethernet0/0/0
#
interface Ethernet0/0/1
#
interface Serial0/0/0
 link-protocol ppp
 ip address 11.0.0.2 255.255.255.252
#
interface Serial0/0/1
 link-protocol ppp
#
interface Serial0/0/2
 link-protocol ppp
#
interface Serial0/0/3
 link-protocol ppp
#
interface GigabitEthernet0/0/0
#
interface GigabitEthernet0/0/0.100
 dot1q termination vid 100
 ip address 192.168.100.1 255.255.255.0
 arp broadcast enable
 dhcp select relay
 dhcp relay server-ip 23.0.0.2
#
interface GigabitEthernet0/0/0.200
 dot1q termination vid 200
 ip address 192.168.200.1 255.255.255.0
 arp broadcast enable
 dhcp select relay
 dhcp relay server-ip 23.0.0.2
#
interface GigabitEthernet0/0/1
 ip address 23.0.0.1 255.255.255.0
#
interface GigabitEthernet0/0/2
#
interface GigabitEthernet0/0/3
#
wlan
#
interface NULL0
#
ip route-static 0.0.0.0 0.0.0.0 23.0.0.2
ip route-static 192.168.0.0 255.255.0.0 11.0.0.1
#

R3

#
sysname Huawei
#
dhcp enable
#
ip pool dhcp100
 gateway-list 192.168.100.1
 network 192.168.100.0 mask 255.255.255.0
 dns-list 8.8.8.8 2.2.2.2
#
ip pool dhcp200
 gateway-list 192.168.200.1
 network 192.168.200.0 mask 255.255.255.0
 dns-list 8.8.8.8 2.2.2.2
#
aaa
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default
 domain default_admin
 local-user admin password cipher -$[1(P>3t>+/[email protected]:Y>Lw(YM6#
 local-user admin service-type http
#
firewall zone Local
 priority 16
#
interface Ethernet0/0/0
#
interface Ethernet0/0/1
#
interface Serial0/0/0
 link-protocol ppp
#
interface Serial0/0/1
 link-protocol ppp
#
interface Serial0/0/2
 link-protocol ppp
#
interface Serial0/0/3
 link-protocol ppp
#
interface GigabitEthernet0/0/0
#
interface GigabitEthernet0/0/1
 ip address 23.0.0.2 255.255.255.0
 dhcp select global
#
interface GigabitEthernet0/0/2
#
interface GigabitEthernet0/0/3
#
wlan
#
interface NULL0
#
ip route-static 0.0.0.0 0.0.0.0 23.0.0.1
#

LSW5

#
sysname SW5
#
vlan batch 100 200
#
cluster enable
ntdp enable
ndp enable
#
drop illegal-mac alarm
#
diffserv domain default
#
drop-profile default
#
aaa
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default
 domain default_admin
 local-user admin password simple admin
 local-user admin service-type http
#
interface Vlanif1
#
interface MEth0/0/1
#
interface Ethernet0/0/1
 port link-type access
 port default vlan 100
#
interface Ethernet0/0/2
 port link-type access
 port default vlan 200
#
interface Ethernet0/0/3
#
interface Ethernet0/0/4
#
interface Ethernet0/0/5
#
interface Ethernet0/0/6
#
interface Ethernet0/0/7
#
interface Ethernet0/0/8
#
interface Ethernet0/0/9
#
interface Ethernet0/0/10
#
interface Ethernet0/0/11
#
interface Ethernet0/0/12
#
interface Ethernet0/0/13
#
interface Ethernet0/0/14
#
interface Ethernet0/0/15
#
interface Ethernet0/0/16
#
interface Ethernet0/0/17
#
interface Ethernet0/0/18
#
interface Ethernet0/0/19
#
interface Ethernet0/0/20
#
interface Ethernet0/0/21
#
interface Ethernet0/0/22
#
interface GigabitEthernet0/0/1
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094
#

測試是否有BUG

1、PC5、PC6能獲取到DHCP服務器提供的IP地址
華爲綜合實驗——單臂、三層交換、動靜路由、VRRP路由、DHCP中繼、捆綁Etrunk
華爲綜合實驗——單臂、三層交換、動靜路由、VRRP路由、DHCP中繼、捆綁Etrunk

2、四臺pc能實現數據的互聯互通

華爲綜合實驗——單臂、三層交換、動靜路由、VRRP路由、DHCP中繼、捆綁Etrunk
華爲綜合實驗——單臂、三層交換、動靜路由、VRRP路由、DHCP中繼、捆綁Etrunk
華爲綜合實驗——單臂、三層交換、動靜路由、VRRP路由、DHCP中繼、捆綁Etrunk
華爲綜合實驗——單臂、三層交換、動靜路由、VRRP路由、DHCP中繼、捆綁Etrunk

由此,實驗配置毫無problem,請小夥伴們自行配置,切不可將代碼照抄照搬。。。

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章