Largest Rectangle in a Histogram【單調棧模板】

Largest Rectangle in a Histogram

題目鏈接(點擊)來源poj 2559


    A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles: Description


    Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.

Input

The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1<=n<=100000. Then follow n integers h1,...,hn, where 0<=hi<=1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.

Output

For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.

Sample Input

7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0

Sample Output

8
4000

Hint

Huge input, scanf is recommended.

題意:

   給出柱狀圖各個柱子的高度,計算最大矩形面積。

思路:

   對每個柱子找到最大的寬的長度,將面積存進數組sort,輸出最大面積。

具體實現:

   要利用單調棧,下面給出兩種代碼,分別是記錄左右區間和不記錄區間只找出最大寬度。

 1、記錄左右區間(例題:Largest Rectangle in a Histogram) 感謝:Frank__Chen

#include<stdio.h>
#include<algorithm>
using namespace std;
typedef long long LL;
const LL MAX=1e5;
LL n;
LL high[MAX+5];
LL top;
LL Stack[MAX+5],l[MAX+5],r[MAX+5];
int main()
{
    while(scanf("%lld",&n)!=EOF){
        if(n==0){
            break;
        }
        for(LL i=1;i<=n;i++){
            scanf("%lld",&high[i]);
        }
        high[0]=-1,high[n+1]=-1;
        top=0;
        Stack[top]=0;
        for(LL i=1;i<=n;i++){
            while(high[Stack[top]]>=high[i]) top--;
            l[i]=Stack[top];
            Stack[++top]=i;
        }
        top=0;
        Stack[top]=n+1;
        for(LL i=n;i>=1;i--){
            while(high[Stack[top]]>=high[i]) top--;
            r[i]=Stack[top];
            Stack[++top]=i;
        }
        LL maxx=-MAX;
        for(LL i=1;i<=n;i++){
            maxx=max(maxx,(r[i]-l[i]-1)*high[i]);
        }
        printf("%lld\n",maxx);
    }
    return 0;
}

  2、直接利用單調棧性質計算最大寬度   感謝:Parsnip_

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章