POJ 1337

A Lazy Worker
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 1144   Accepted: 388

Description

There is a worker who may lack the motivation to perform at his peak level of efficiency because he is lazy. He wants to minimize the amount of work he does (he is Lazy, but he is subject to a constraint that he must be busy when there is work that he can do.) 

We consider a set of jobs 1, 2,..., n having processing times t1, t2,...,tn respectively. Job i arrives at time ai and has its deadline at time di. We assume that ti, ai, and di have nonnegative integral values. The jobs have hard deadlines, meaning that each job i can only be executed during its allowed interval Ii=[ai, di]. The jobs are executed by the worker, and the worker executes only one job at a time. Once a job is begun, it must be completed without interruptions. When a job is completed, another job must begin immediately, if one exists to be executed. Otherwise, the worker is idle and begins executing a job as soon as one arrives. You should note that for each job i, the length of Ii, di - ai, is greater than or equal to ti, but less than 2*ti. 

Write a program that finds the minimized total amount of time executed by the worker. 

Input

The input consists of T test cases. The number of test cases (T ) is given in the first line of the input file. The number of jobs (0<=n<=100) is given in the first line of each test case, and the following n lines have each job's processing time(1<=ti<=20),arrival time(0<=ai<=250), and deadline time (1<=di<=250) as three integers.

Output

Print exactly one line for each test case. The output should contain the total amount of time spent working by the worker.

Sample Input

3
3
15 0 25
50 0 90
45 15 70
3
15 5 20
15 25 40
15 45 60
5
3 3 6
3 6 10
3 14 19
6 7 16
4 4 11

Sample Output

50
45
15

Source



#include <vector>
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std;
#define INF 0x3f3f3f3f
#define N 110
#define M 260

int n, a[N], d[N], t[N];
int dp[M];
vector<int> G[M];

// dp[i] = min(dp[i + cost[j]] + cost[j]); means the minimum working time form now to endtime.

int main(){
	freopen("I.txt", "r", stdin);
	int _T;
	scanf("%d", &_T);
	while(_T--){
		int Begin = INF, End = 0;
		scanf("%d", &n);
		for(int i = 1; i <= n; i++){
			scanf("%d%d%d", &t[i], &a[i], &d[i]);
			End = max(End, d[i]);
			Begin = min(Begin, a[i]);
		}

		for(int i = Begin; i <= End; i++){
			G[i].clear();
			for(int j = 1; j <= n; j++){
				if(i >= a[j] && i + t[j] <= d[j]) {
					G[i].push_back(j);
				}
			}
		}

		dp[End] = 0;
		for(int i = End - 1; i >= Begin; i--){
			if(!G[i].size()) dp[i] = dp[i + 1];
			else {
				int Size = G[i].size();
				dp[i] = INF;
				for(int j = 0; j < Size; j++){
					int time = t[G[i][j]];
					dp[i] = min(dp[i], dp[i + time] + time);
				}
			}
		}


		printf("%d\n", dp[Begin]);
	}
	return 0;
}


發佈了274 篇原創文章 · 獲贊 19 · 訪問量 21萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章