hdu 1005 Number Sequence(智尋循環節)

Description

A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output

For each test case, print the value of f(n) on a single line.
 

Sample Input

1 1 3 1 2 10 0 0 0
 

Sample Output

2 5

對於這條公式f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7

A和B是確定的,而 f(n - 1)和 f(n - 2)均爲0-6總共7個數,所以 (A * f(n - 1) + B * f(n - 2))的值最多有49種可能,而一對相鄰數字的組合最多爲49^49種,所以在這個範圍內爆搜決定可以找出循環節


代碼:

#include <cstring>
#include <cstdio>
#include <cstdlib>
using namespace std;

int rec[2500];

int main()
{
    int a, b, n;
	rec[1] = rec[2] = 1;
    scanf( "%d %d %d", &a, &b, &n );
    while(!(a==0&&b==0&&n==0))
    {
        int beg, end, flag = 0;
        for( int i = 3; i <= n && !flag; ++i )
        {
            rec[i] = ( a * rec[i-1] + b * rec[i-2] ) % 7;
            for( int j = 2; j <= i - 1; ++j )
            {
                if( rec[i] == rec[j] && rec[i-1] == rec[j-1] )
                {
                    beg = j, end = i;
                    flag = 1;
                    break;
                }
            }
        }
        if( flag )
        {
            printf( "%d\n", rec[beg+(n-end)%(end-beg)] );
        }
        else
            printf( "%d\n", rec[n] );
        scanf( "%d %d %d", &a, &b, &n );
    }
    return 0;
}


發佈了29 篇原創文章 · 獲贊 4 · 訪問量 1萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章