HDU 5532 Almost Sorted Array (dp)

Almost Sorted Array

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 2508    Accepted Submission(s): 619


Problem Description
We are all familiar with sorting algorithms: quick sort, merge sort, heap sort, insertion sort, selection sort, bubble sort, etc. But sometimes it is an overkill to use these algorithms for an almost sorted array.

We say an array is sorted if its elements are in non-decreasing order or non-increasing order. We say an array is almost sorted if we can remove exactly one element from it, and the remaining array is sorted. Now you are given an array a1,a2,,an, is it almost sorted?
 

Input
The first line contains an integer T indicating the total number of test cases. Each test case starts with an integer n in one line, then one line with n integers a1,a2,,an.

1T2000
2n105
1ai105
There are at most 20 test cases with n>1000.
 

Output
For each test case, please output "`YES`" if it is almost sorted. Otherwise, output "`NO`" (both without quotes).
 

Sample Input
3 3 2 1 7 3 3 2 1 5 3 1 4 1 5
 

Sample Output
YES YES NO
 

Source
2015ACM/ICPC亞洲區長春站-重現賽(感謝東北師大)


題意:這題題意應該比較清晰,就是問你給出隊列是否可以取去一個數後變成非嚴格遞增或非嚴格遞減的序列,可以輸出YES,不行輸出NO。

解題思路:先假可以,那麼該子序列的非嚴格單調上升長度爲len1,非嚴格單調遞減子序列長度爲len2,滿足max(len1,len2)>=n,所以只要求出這兩個長度即可,然後加以判斷。

<span style="font-size:18px;">#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
using namespace std;
const int maxn=100005;
int a[maxn],b[maxn];
vector<int> v;
int main()
{
    int t,n;
    scanf("%d",&t);
    while(t--)
    {
        v.clear();
        scanf("%d",&n);
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);
        vector<int>::iterator it=v.begin();
        for(int i=0;i<n;i++)
        {
            if((it=upper_bound(v.begin(),v.end(),a[i]))==v.end())
                 v.push_back(a[i]);
            else
                *it=a[i];
        }
        int ans=v.size();
        v.clear();
        for(int i=n-1;i>=0;i--)
        {
            if((it=upper_bound(v.begin(),v.end(),a[i]))==v.end())
                v.push_back(a[i]);
            else
                *it=a[i];
        }
        int ans1=v.size();
        if(ans>=n-1 || ans1>=n-1)
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}</span>


發佈了106 篇原創文章 · 獲贊 5 · 訪問量 5萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章