hdu1164Eddy's research I(素數)

Eddy's research I

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11842    Accepted Submission(s): 7288


http://acm.hdu.edu.cn/showproblem.php?pid=1164

Problem Description

Eddy's interest is very extensive, recently he is interested in prime number. Eddy discover the all number owned can be divided into the multiply of prime number, but he can't write program, so Eddy has to ask intelligent you to help him, he asks you to write a program which can do the number to divided into the multiply of prime number factor .
 

 

 

Input

The input will contain a number 1 < x<= 65535 per line representing the number of elements of the set.

 

 

Output

You have to print a line in the output for each entry with the answer to the previous question.

 

 

Sample Input

11

9412

 

 

Sample Output

11

2*2*13*181

題意:把n寫成素數相乘形式。

 

代碼:

#include<iostream>
#include<cstring>
#include<cmath>
#include<iomanip>
#define inf 0x3f3f3f3f
using namespace std;

int main()
{
    int n;
    while(cin>>n)
    {
        for(int i=2;i<=n;i++)
        {
            while(n%i==0)
            {
                if(n/i==1)
                {
                    cout<<i<<endl;
                    break;
                }
                else
                {
                    cout<<i<<"*";
                    n/=i;
                }
            }
        }
    }
    return 0;
}

 

發佈了200 篇原創文章 · 獲贊 89 · 訪問量 7萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章