PAT_1050: String Subtraction

Given two strings S1 and S2, S = S1 - S2 is defined to be the remaining string after taking all the characters in S2 from S1. Your task is simply to calculate S1 - S2 for any given strings. However, it might not be that simple to do it fast.

Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S1 and S2, respectively. The string lengths of both strings are no more than 104. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:

For each test case, print S1 - S2 in one line.

Sample Input:
They are students.
aeiou
Sample Output:
Thy r stdnts.
備註:簡單題,直接用哈希的思想查找即可。
#include<stdio.h>

int main()
{
	char s1[10005],s2[10005];
	int map[1000]={0};

	gets(s1);
	gets(s2);

	for(int i=0;s2[i]!='\0';i++)
		map[s2[i]]=1;

	for(int i=0;s1[i]!='\0';i++)
	{
		if(map[s1[i]]==0)
			printf("%c",s1[i]);
	}

	return 0;
}


發佈了58 篇原創文章 · 獲贊 0 · 訪問量 4萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章