HDU - 6198 number number number(規律+矩陣快速冪)

number number number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 274    Accepted Submission(s): 174


Problem Description
We define a sequence F:

 F0=0,F1=1;
 Fn=Fn1+Fn2 (n2).

Give you an integer k, if a positive number n can be expressed by
n=Fa1+Fa2+...+Fak where 0a1a2ak, this positive number is mjfgood. Otherwise, this positive number is mjfbad.
Now, give you an integer k, you task is to find the minimal positive mjfbad number.
The answer may be too large. Please print the answer modulo 998244353.
 

Input
There are about 500 test cases, end up with EOF.
Each test case includes an integer k which is described above. (1k109)
 

Output
For each case, output the minimal mjfbad number mod 998244353.
 

Sample Input
1
 

Sample Output
4
 

Source
 

Recommend
liuyiding
 

Statistic | Submit | Discuss | Note

題意:輸入一個 k ,輸出最小的不能由 k 個斐波那契數相加得到的正整數 n;

這題打表找規律,k = 1時 n = 4, k = 2時 n = 12,k = 3時 n = 33 ……規律即斐波那契數列的第 4+2*(k-1)項-1,最後用矩陣快速冪加速計算即可

#include <bits/stdc++.h>
using namespace std;

const long long N = 2, Mod = 998244353;
long long m, n;
struct xx{
    long long a[N][N];
} ori,res;

xx mul(xx x,xx y){
    xx temp;
    memset(temp.a, 0, sizeof(temp.a));
    for(int i = 0; i < N; i++){
        for(int j = 0; j < N; j++){
            for(int k = 0; k < N; k++){
                temp.a[i][j] += x.a[i][k]*y.a[k][j];
                temp.a[i][j] %= Mod;
            }
        }
    }
    return temp;
}

void init(){
    ori.a[0][0] = 1, ori.a[0][1] = 1;
    ori.a[1][0] = 1, ori.a[1][1] = 0;
    res.a[0][0] = 1, res.a[0][1] = 0;
    res.a[1][0] = 0, res.a[1][1] = 1;
}

long long calc(long long k){
    while(k){
        if(k & 1) res = mul(res, ori);
        ori = mul(ori, ori);
        k >>= 1;
    }
    return res.a[0][0];
}

int main(){
    while(scanf("%lld", &m) == 1){
        init();
        n = 4+(m-1)*2;
        printf("%lld\n", calc(n)-1);
    }
}


發佈了133 篇原創文章 · 獲贊 5 · 訪問量 3萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章