Values whose Sum is 0 (二分查找)

Description
The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .

Input
The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 2 28 ) that belong respectively to A, B, C and D .

Output
For each input file, your program has to write the number quadruplets whose sum is zero.

Sample Input

6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45

Sample Output

5

Hint
Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).

思路:先求出左邊兩列的和的所有情況,再求出右邊兩列的和的所有情況,在二分查找右邊兩列的和與左邊兩列的和等於零的情況。

#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
int a[4010][4],sum1[16000010],sum2[16000010];
int n,mid;
int main()
{
    while(scanf("%d",&n) != EOF)
    {
        int k = 0, m = 0, c = 0;
        for(int i=0; i<n; i++)
        {
            scanf("%d %d %d %d",&a[i][0],&a[i][1], &a[i][2],&a[i][3]);
        }

        for(int i=0; i<n; i++)
            for(int j=0; j<n; j++)
            {
                sum1[k++]=a[i][0]+a[j][1];
                sum2[m++]=a[i][2]+a[j][3];
            }
        sort(sum2, sum2 + k);

        for(int i=0; i<k; i++)
        {
            int l=0;
            int r=k-1;
            while(l <= r)
            {
                mid=(l+r)/2;
                if(sum1[i]+sum2[mid]==0)
                {
                    c++;
                    for(int j=mid+1; j<k; j++)
                    {
                        if(sum1[i]+sum2[j]!=0)
                            break;
                        else
                            c++;
                    }
                    for(int j=mid-1; j>=0; j--)
                    {
                        if(sum1[i]+sum2[j]!=0)
                            break;
                        else
                            c++;
                    }
                    break;
                }
                if(sum1[i]+sum2[mid]<0)
                    l=mid+1;
                else
                    r=mid-1;
            }
        }
        printf("%d\n",c);
    }
    return 0;
}
發佈了33 篇原創文章 · 獲贊 2 · 訪問量 7619
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章