1154. Easy sort ……sort

1154. Easy sort

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

You know sorting is very important. And this easy problem is:

Given you an array with N non-negative integers which are smaller than 10,000,000, you have to sort this array. Sorting means that integer with smaller value presents first.

Input

The first line of the input is a positive integer T. T is the number of the test cases followed.

The first line of each test case is a positive integer N (1<= N<= 1000) which represents the number of integers in the array. After that, N lines followed. The i-th line is the i-th integer in the array.

Output

The output of each test case should consist of N lines. The i-th line is the i-th integer of the array after sorting. No redundant spaces are needed.

Sample Input

2312311

Sample Output

1231

Problem Source

ZSUACM Team Member


#include <iostream>
#include <algorithm>

using namespace std;

int main () {
	int T;
	cin>>T;
	while (T--) {
		int n;
		cin>>n;
		int a[1005];
		for (int i = 0; i < n; i++) {
			cin >> a[i];
		}
		sort(a, a + n);
		for (int i = 0; i < n; i++) {
			cout<<a[i]<<endl;
		}
	}
	
	//system("pause");
	return 0;
}


發佈了42 篇原創文章 · 獲贊 4 · 訪問量 5萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章