The ? 1 ? 2 ? ... ? n = k problem

Given the following formula, one can set operators ‘+’ or ‘-’ instead of each ‘?’, in order to obtain a
given k
?1?2? . . .?n = k
For example: to obtain k = 12, the expression to be used will be:
- 1 + 2 + 3 + 4 + 5 + 6 - 7 = 12
with n = 7
Input
The first line is the number of test cases, followed by a blank line.
Each test case of the input contains an integer k (0 ≤ |k| ≤ 1000000000).
Each test case will be separated by a single line.
Output
For each test case, your program should print the minimal possible n (1 ≤ n) to obtain k with the
above formula.
Print a blank line between the outputs for two consecutive test cases.
Sample Input
2
12
-3646397
Sample Output
7

2701


      這個題思路是先求1+2+3+……+n>k的最小n,然後判斷1+2+……+n的和減去k是否爲偶數,若爲偶數,則n即爲所求,若不是,則n++重複剛纔的判斷。把k都當做正數做,它們只差了個符號,在本題沒有影響

#include<stdio.h>
#include<stdlib.h>
int main()
{
	int t;
	scanf("%d",&t);
	getchar();
	while(t--)
	{
		int n,sum = 0;
		scanf("%d",&n);
		getchar();
		
		n = abs(n);
		int i;
		for(i=1;;i++)
		{
			sum+=i;
			if(sum>=n&&!((sum-n)%2))
			 break;
			 
		}
		printf("%d\n",i);
		if(t) 
		printf("\n");
	}
 } 



發佈了39 篇原創文章 · 獲贊 3 · 訪問量 1萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章