A - Can you find it?解題報告

A - Can you find it?
Time Limit:3000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u

Description

Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.
 

Input

There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.
 

Output

For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".
 

Sample Input

3 3 3 1 2 3 1 2 3 1 2 3 3 1 4 10
 

Sample Output

Case 1: NO YES NO
 

這個題目的意思呢就是從三組數中分別拉一個數出來,如果和==X的話就輸出“YES”,否則輸出“NO”;一開始雖然知道用硬的來時會超時,可是還是抱有僥倖的心態,結果TLE;還是用二分吧。這個二分首先將兩個數組的和加起來,就是先開一個250001的數組,然後sort排序,然後呢就查找咯;
看代碼把:

#include<iostream>
#include<algorithm>
using namespace std;
int main()
{
	int a[501],b[501],c[501],d[250001],L,N,M,k=0,i,j,qq=1,n,S;
	while(cin>>L>>N>>M)
	{
		k=0;
		for(i=0;i<L;i++)
			cin>>a[i];
		for(i=0;i<N;i++)
			cin>>b[i];
		for(i=0;i<M;i++)
			cin>>c[i];
		for(i=0;i<L;i++)
			for(j=0;j<N;j++)
				d[k++]=a[i]+b[j];
			sort(d,d+k);
			cin>>n;
			cout<<"Case "<<qq<<':'<<endl;
			for(i=0;i<n;i++)
			{
				cin>>S;
				for(j=0;j<M;j++)
				{
					int temp=S-c[j];
					int left=0,right=k-1,mid;
					while(left<right)
					{
						mid=(left+right)/2;
						if(d[mid]==temp)
						{
						cout<<"YES"<<endl;
							goto end;
						}
						else if(temp>d[mid])
						{
							left=mid+1;
						}
						else
						{
							right=mid;
						}
					}
				}
				cout<<"NO"<<endl;
end:;
			}
			qq++;
	}
	return 0;
}




發佈了44 篇原創文章 · 獲贊 8 · 訪問量 2萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章