Let the Balloon Rise

Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 37885    Accepted Submission(s): 13036


Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you. 
 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.
 

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
 

Sample Input
5 green red blue red red 3 pink orange pink 0
 

Sample Output
red pink
 

Author
WU, Jiazhi
 

Source
 

Recommend
JGShining
 
這個題目不解釋了,,基礎
#include<iostream>
#include<string>
using namespace std;
int main()
{
	int n,i,j,sum=0,sun=0;
	string word[1001],a;
	while(cin>>n&&n!=0)
	{
		for(i=0;i<n;i++)
			cin>>word[i];
		for(i=0;i<n;i++)
		{
			for(j=0;j<n;j++)
				if(word[i]==word[j])
				{
					sun++;
				}
				if(sun>sum)
					{
						sum=sun;
						a=word[i];
					}
				sun=0;
		}
		sum=0;
				cout<<a<<endl;
	}
}


發佈了44 篇原創文章 · 獲贊 8 · 訪問量 2萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章