hdu 5360 Hiking(2015 Multi-University Training Contest 6)

Hiking

                                                          Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
                                                                                     Total Submission(s): 126    Accepted Submission(s): 75
                                                                                                                                    Special Judge


Problem Description
There are n soda conveniently labeled by 1,2,,n. beta, their best friends, wants to invite some soda to go hiking. The i-th soda will go hiking if the total number of soda that go hiking except him is no less than li and no larger than ri. beta will follow the rules below to invite soda one by one:
1. he selects a soda not invited before;
2. he tells soda the number of soda who agree to go hiking by now;
3. soda will agree or disagree according to the number he hears.

Note: beta will always tell the truth and soda will agree if and only if the number he hears is no less than li and no larger than ri, otherwise he will disagree. Once soda agrees to go hiking he will not regret even if the final total number fails to meet some soda's will.

Help beta design an invitation order that the number of soda who agree to go hiking is maximum.
 

Input
There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:

The first contains an integer n (1n105), the number of soda. The second line constains n integers l1,l2,,ln. The third line constains n integers r1,r2,,rn(0lirin)
It is guaranteed that the total number of soda in the input doesn't exceed 1000000. The number of test cases in the input doesn't exceed 600.
 

Output
For each test case, output the maximum number of soda. Then in the second line output a permutation of 1,2,,n denoting the invitation order. If there are multiple solutions, print any of them.
 

Sample Input
4 8 4 1 3 2 2 1 0 3 5 3 6 4 2 1 7 6 8 3 3 2 0 5 0 3 6 4 5 2 7 7 6 7 6 8 2 2 3 3 3 0 0 2 7 4 3 6 3 2 2 5 8 5 6 5 3 3 1 2 4 6 7 7 6 5 4 3 5
 

Sample Output
7 1 7 6 5 2 4 3 8 8 4 6 3 1 2 5 8 7 7 3 6 7 1 5 2 8 4 0 1 2 3 4 5 6 7 8
 

Source
 

題目大意:
       soda邀請一些人,當同意的人數在li~ri區間內,他就會同意,求該如何詢問,會讓同意的人儘可能多。

解題思路:
       將在當前可能同意的區間內選右區間最小的。

代碼:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
using namespace std;
const int maxn=100000+1000;
struct node
{
    int l,r,cur;
    bool operator < (const node& a) const
    {
        return r>a.r;
    }
} a[maxn];
int vis[maxn];
int pre[maxn];
bool cmp(node x,node y)
{
    return x.l<y.l;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,ans;
        scanf("%d",&n);
        for(int i=0; i<n; i++)
        {
            scanf("%d",&a[i].l);
            a[i].cur=i+1;
        }
        for(int i=0; i<n; i++)
        {
            scanf("%d",&a[i].r);
        }
        sort(a,a+n,cmp);
        priority_queue<node> q;
        memset(vis,0,sizeof(vis));
        ans=0;
        for(int i=0; i<n;)
        {
            if(a[i].l<=ans)
            {
                q.push(a[i]);
               // cout<<i<<endl;
                i++;
            }
            else
            {
                if(q.empty())
                    break;
                else
                {
                    while(!q.empty())
                    {
                        node p=q.top();
                        q.pop();
                      //  cout<<p.r<<"  "<<ans<<endl;
                        if(p.r>=ans)
                        {
                            pre[++ans]=p.cur;
                            vis[p.cur]=1;
                            break;
                        }
                    }
                }
            }
        }
        while(!q.empty())
        {
            node p=q.top();
            q.pop();
            if(p.r>=ans)
            {
                pre[++ans]=p.cur;
                vis[p.cur]=1;
            }
        }
        printf("%d\n",ans);
        if(ans>0)
        {
            printf("%d",pre[1]);
            for(int i=2; i<=ans; i++)
            {
                printf(" %d",pre[i]);
            }
            for(int i=1; i<=n; i++)
            {
                if(!vis[i])
                    printf(" %d",i);
            }
            printf("\n");
        }
        else
        {
            printf("1");
            for(int i=2; i<=n; i++)
                printf(" %d",i);
            printf("\n");
        }
    }
    return 0;
}


發佈了249 篇原創文章 · 獲贊 7 · 訪問量 56萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章