Cleaning Shifts POJ - 2376

Farmer John is assigning some of his N (1 <= N <= 25,000) cows to do some cleaning chores around the barn. He always wants to have one cow working on cleaning things up and has divided the day into T shifts (1 <= T <= 1,000,000), the first being shift 1 and the last being shift T. 

Each cow is only available at some interval of times during the day for work on cleaning. Any cow that is selected for cleaning duty will work for the entirety of her interval. 

Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and (ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow to each shift, print -1.
Input
* Line 1: Two space-separated integers: N and T 

* Lines 2..N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start time and finishes after the end time.
Output
* Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.
Sample Input
3 10
1 7
3 6
6 10
Sample Output
2
Hint
This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed. 

INPUT DETAILS: 

There are 3 cows and 10 shifts. Cow #1 can work shifts 1..7, cow #2 can work shifts 3..6, and cow #3 can work shifts 6..10. 

OUTPUT DETAILS: 

By selecting cows #1 and #3, all shifts are covered. There is no way to cover all the shifts using fewer than 2 cows.

題意:有n頭牛,每頭牛的工作時間是從x到y,問你是否可以選擇其中的若干頭牛,使它們的工作時間排滿時間1到t;

若存在,輸出最少需要選擇的牛的數量;若無解,輸出-1.

本來以爲是個並查集,但一看沒法輸出數量,轉而想到了貪心策略,剛開始怎麼貪心可是想懵逼了。

思路:首先進行排序,按照工作結束時間由早到晚,如果結束時間相同,起始時間早的優先;

         設b爲當前未覆蓋區間的初始點,每次選擇包含b的區間中結束時間最晚的牛,如果沒有選擇,那麼無解輸出-1.


代碼:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;
struct node
{
    int x;
    int y;
};
node op[25001];
bool cmp(node a,node b)
{
    if(a.y == b.y) return a.x < b.x;
    return a.y < b.y;
}
int main()
{

    int n,t;
    while(scanf("%d%d", &n,&t) != EOF)
    {
        for(int i=1; i<=n; i++)
        {
            scanf("%d%d", &op[i].x, &op[i].y);
            if(op[i].x < 1) op[i].x = 1;
            if(op[i].y > t) op[i].y = t;
        }
        sort(op+1, op+1+n, cmp);
        int sum = 0;
        int flag = 1;
        int b = 0;
        int s = 0;
        while(s < t)
        {
            b = s+1;
            for(int i=1 ;i<=n; i++)
            {
                if(op[i].x <= b  && op[i].y >= b)
                {
                    if(s < op[i].y) {s=op[i].y;}
                }
            }
            if(s<b){flag=0;break;}
            else ++sum;
        }
        if(flag==0)printf("-1\n");
        else printf("%d\n",sum);
    }
    return 0;
}
水波。
發佈了85 篇原創文章 · 獲贊 5 · 訪問量 1萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章