Constructing Roadster


 Constructing Roads

Crawling in process... Crawling failed Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

    

Description

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.
 

Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.
 

Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.
 

Sample Input

3 0 990 692 990 0 179 692 179 0 1 1 2
                

Sample Output

179
 

#include"cstdio"
#include"cstring"
#include"iostream"

using namespace std;

#define INF 0x7f7f7f7f

int n;
int maze[105][105];
int dis[105];
bool vis[105];

void Prim()
{
    int ans = 0;
    dis[1] = 0;
    vis[1] = true;
    for(int i = 1;i <= n;i++)
    {
        int minn = INF;
        int mark = INF;
        for(int j = 1;j <= n;j++)
        {
            if(!vis[j] && dis[j] < minn)
            {
                minn = dis[j];
                mark = j;
            }
        }
        if(minn == INF)
        {
            break;
        }
        ans += dis[mark];
        vis[mark] = true;
        for(int j = 1;j <= n;j++)
        {
            if(!vis[j] && maze[mark][j] < dis[j])
            {
                dis[j] = maze[mark][j];
            }
        }
    }
    printf("%d\n",ans);
}

int main()
{
    while(~scanf("%d",&n))
    {
        for(int i = 1;i <= n;i++)
        {
            for(int j = 1;j <= n;j++)
            {
                scanf("%d",&maze[i][j]);
            }
        }
        int q;
        scanf("%d",&q);
        while(q--)
        {
            int a,b;
            scanf("%d%d",&a,&b); //已經修建的道路
            maze[a][b] = 0;
            maze[b][a] = 0;
        }
        for(int i = 1;i <= n;i++)
        {
            dis[i] = maze[1][i];
        }
        memset(vis,false,sizeof(vis));
        Prim();
    }
    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章