hdu 4405 Aeroplane chess(概率dp)

Aeroplane chess

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1212    Accepted Submission(s): 825


Problem Description
Hzz loves aeroplane chess very much. The chess map contains N+1 grids labeled from 0 to N. Hzz starts at grid 0. For each step he throws a dice(a dice have six faces with equal probability to face up and the numbers on the faces are 1,2,3,4,5,6). When Hzz is at grid i and the dice number is x, he will moves to grid i+x. Hzz finishes the game when i+x is equal to or greater than N.

There are also M flight lines on the chess map. The i-th flight line can help Hzz fly from grid Xi to Yi (0<Xi<Yi<=N) without throwing the dice. If there is another flight line from Yi, Hzz can take the flight line continuously. It is granted that there is no two or more flight lines start from the same grid.

Please help Hzz calculate the expected dice throwing times to finish the game.
 

Input
There are multiple test cases.
Each test case contains several lines.
The first line contains two integers N(1≤N≤100000) and M(0≤M≤1000).
Then M lines follow, each line contains two integers Xi,Yi(1≤Xi<Yi≤N).  
The input end with N=0, M=0.
 

Output
For each test case in the input, you should output a line indicating the expected dice throwing times. Output should be rounded to 4 digits after decimal point.
 

Sample Input
2 0 8 3 2 4 4 5 7 8 0 0
 

Sample Output
1.1667 2.3441
 
 
題意:有一個飛行棋棋盤,起點在0點,每次投擲一次骰子,之後走骰子上顯示的步數。一些點設有航線,走到這些點時就會飛到指定的地方。給出棋盤的長度以及航線,求到達點n的需要投擲骰子的期望次數。
思路:概率dp入門題,設dp[i]爲到點i時的期望次數,顯然dp[n]=0,最終結果是dp[0]。
易得轉移方程dp[i]=dp[i+1]*(1/6)+dp[i+2]*(1/6)+dp[i+3]*(1/6)+dp[i+4]*(1/6)+dp[i+5]*(1/6)+dp[i+6]*(1/6)+1,
而對於航線xi到yi,dp[xi]=dp[yi]
 
AC代碼:
#include <iostream>
#include <cstring>
#include <cstdio>
#include <queue>
#include <cmath>
#include <algorithm>
#define ll long long

using namespace std;

const int INF = 1e9;
const int maxn = 100010;
const int mod = 100000000;

vector<int> G[maxn];
int n, m;
bool vis[maxn];
double dp[maxn];
int main()
{
    int a, b;
    while(scanf("%d%d", &n, &m), n || m)
    {
        for(int i = 1; i <= n; i++) G[i].clear();
        memset(vis, false, sizeof(vis));
        memset(dp, 0, sizeof(dp));
        dp[n] = 0;
        while(m--)
        {
            scanf("%d%d", &a, &b);
            G[b].push_back(a);
        }
        for(int i = 0; i < (int)G[n].size(); i++)
        {
            int v = G[n][i];
            dp[v] = 0;
            vis[v] = true;
        }
        for(int i = n - 1; i >= 0; i--)
        {
            if(!vis[i])
            {
                for(int j = i + 1; j <= i + 6; j++)
                dp[i] += dp[j] / 6;
                dp[i] += 1;
            }
            for(int j = 0; j < (int)G[i].size(); j++)
            {
                int v = G[i][j];
                dp[v] = dp[i];
                vis[v] = true;
            }
        }
        printf("%.4f\n", dp[0]);
    }
    return 0;
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章