UVa OJ 10361 自動作詩機

Problem 

Automatic Poetry

Input: standard input

Output: standard output

Time Limit: 2 seconds

Memory Limit: 32 MB

“Oh God”, Lara Croft exclaims, “it’s one of these dumb riddles again!”

In Tomb Raider XIV, Lara is, as ever, gunning her way through ancient Egyptian pyramids, prehistoric caves and medival hallways. Now she is standing in front of some important Germanic looking doorway and has to solve a linguistic riddle to pass. As usual, the riddle is not very intellectually challenging.

This time, the riddle involves poems containing a “Schuttelreim”. An example of a Schuttelreim is the following short poem:

Ein Kind halt seinen Schnabel nur,

wenn es hangt an der Nabelschnur.        

/*German contestants please forgive me. I had to modify something as they were not appearing correctly in plain text format*/

A Schuttelreim seems to be a typical German invention. The funny thing about this strange type of poetry is that if somebody gives you the first line and the beginning of the second one, you can complete the poem yourself. Well, even a computer can do that, and your task is to write a program which completes them automatically. This will help Lara concentrate on the “action” part of Tomb Raider and not on the “intellectual” part.

Input

The input will begin with a line containing a single number n. After this line follow n pairs of lines containing Schuttelreims. The first line of each pair will be of the form

s1<s2>s3<s4>s5

where the si are possibly empty, strings of lowercase characters or blanks. The second line will be a string of lowercase characters or blanks ending with three dots “...”. Lines will we at most 100 characters long.

Output

For each pair of Schuttelreim lines l1 and l2 you are to output two lines c1 and c2 in the following way: c1 is the same as l1 only that the bracket marks “<” and “>” are removed. Line c2 is the same as l2 , except that instead of the three dots the string s4s3s2s5 should appear.

Sample Input

3

ein kind haelt seinen <schn>abel <n>ur

wenn es haengt an der ...

weil wir zu spaet zur <>oma <k>amen

verpassten wir das ...

<d>u <b>ist

...

Sample Output

ein kind haelt seinen schnabel nur

wenn es haengt an der nabel schnur

weil wir zu spaet zur oma kamen

verpassten wir das koma amen

du bist

bu dist


#include <stdio.h>
#include <string.h>

int main()
{
	int n,i;
	char ch[4][100],temp;
	scanf("%d",&n);
	getchar();
	while(n--)
	{
		for(i=0;i<4;i++)//初始化
			memset(ch[i],0,sizeof(ch[i]));

		for(i=0;(temp=getchar())!='<';i++)//直接輸出s1
			putchar(temp);
		for(i=0;(temp=getchar())!='>';i++)//存儲s2
		{
			putchar(temp);
			ch[0][i]=temp;
		}
		for(i=0;(temp=getchar())!='<';i++)
		{
			putchar(temp);
			ch[1][i]=temp;
		}
		for(i=0;(temp=getchar())!='>';i++)
		{
			putchar(temp);
			ch[2][i]=temp;
		}
		for(i=0;(temp=getchar())!='\n';i++)
		{
			putchar(temp);
			ch[3][i]=temp;
		}
		putchar('\n');
		for(i=0;(temp=getchar())!='.';i++)
			putchar(temp);
		while((temp=getchar())!='\n')//把緩衝區中剩餘的兩個“..”消除
			;
		printf("%s%s%s%s\n",ch[2],ch[1],ch[0],ch[3]);
	}
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章