hdu 5025 Saving Tang Monk bfs+優先隊列 2014 ACM/ICPC Asia Regional Guangzhou Online

Saving Tang Monk

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 732    Accepted Submission(s): 278


Problem Description
《Journey to the West》(also 《Monkey》) is one of the Four Great Classical Novels of Chinese literature. It was written by Wu Cheng'en during the Ming Dynasty. In this novel, Monkey King Sun Wukong, pig Zhu Bajie and Sha Wujing, escorted Tang Monk to India to get sacred Buddhism texts. 

During the journey, Tang Monk was often captured by demons. Most of demons wanted to eat Tang Monk to achieve immortality, but some female demons just wanted to marry him because he was handsome. So, fighting demons and saving Monk Tang is the major job for Sun Wukong to do.

Once, Tang Monk was captured by the demon White Bones. White Bones lived in a palace and she cuffed Tang Monk in a room. Sun Wukong managed to get into the palace. But to rescue Tang Monk, Sun Wukong might need to get some keys and kill some snakes in his way.

The palace can be described as a matrix of characters. Each character stands for a room. In the matrix, 'K' represents the original position of Sun Wukong, 'T' represents the location of Tang Monk and 'S' stands for a room with a snake in it. Please note that there are only one 'K' and one 'T', and at most five snakes in the palace. And, '.' means a clear room as well '#' means a deadly room which Sun Wukong couldn't get in.

There may be some keys of different kinds scattered in the rooms, but there is at most one key in one room. There are at most 9 kinds of keys. A room with a key in it is represented by a digit(from '1' to '9'). For example, '1' means a room with a first kind key, '2' means a room with a second kind key, '3' means a room with a third kind key... etc. To save Tang Monk, Sun Wukong must get ALL kinds of keys(in other words, at least one key for each kind).

For each step, Sun Wukong could move to the adjacent rooms(except deadly rooms) in 4 directions(north, west, south and east), and each step took him one minute. If he entered a room in which a living snake stayed, he must kill the snake. Killing a snake also took one minute. If Sun Wukong entered a room where there is a key of kind N, Sun would get that key if and only if he had already got keys of kind 1,kind 2 ... and kind N-1. In other words, Sun Wukong must get a key of kind N before he could get a key of kind N+1 (N>=1). If Sun Wukong got all keys he needed and entered the room in which Tang Monk was cuffed, the rescue mission is completed. If Sun Wukong didn't get enough keys, he still could pass through Tang Monk's room. Since Sun Wukong was a impatient monkey, he wanted to save Tang Monk as quickly as possible. Please figure out the minimum time Sun Wukong needed to rescue Tang Monk.
 

Input
There are several test cases.

For each case, the first line includes two integers N and M(0 < N <= 100, 0<=M<=9), meaning that the palace is a N×N matrix and Sun Wukong needed M kinds of keys(kind 1, kind 2, ... kind M). 

Then the N × N matrix follows.

The input ends with N = 0 and M = 0.
 

Output
For each test case, print the minimum time (in minutes) Sun Wukong needed to save Tang Monk. If it's impossible for Sun Wukong to complete the mission, print "impossible"(no quotes).
 

Sample Input
3 1 K.S ##1 1#T 3 1 K#T .S# 1#. 3 2 K#T .S. 21. 0 0
 

Sample Output
5 impossible 8
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:  5041 5040 5039 5038 5037 
 

題意:給出一張圖,K表示起點位置,T表示終點位置,S表示有蛇的房間,走過帶蛇的房間的時候需要額外的一點時間,數字表示鑰匙,#表示不可達,'.'表示普通路,要到終點時必須拿到第k把鑰匙,拿鑰匙的規則,要拿第n把鑰匙,需要首先拿到第n-1把鑰匙。

思路:一開始沒想是bfs,賽後看題解做的,用vis標記剔除無用路徑,優先隊列按時間小頂堆,就這樣了,不知c++爲何tle,g++375ms

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cstdlib>
#include <cmath>
#include <vector>
#include <queue>
#include <map>
using namespace std;
const int N=105;
char mp[N][N];
bool vis[N][N][10][1<<5];
int dx[]={1,0,-1,0};
int dy[]={0,1,0,-1};
int n,k,stx,sty;
struct node{
    int x,y;
    int time,key,s;
    node(int a,int b,int t,int k,int ss){x=a;y=b;time=t;key=k;s=ss;}
    friend bool operator< (node a,node b){
        return a.time>b.time;
    }
};
priority_queue <node> que;
void init(){
    int c='a';
    for(int i=0;i<n;i++){
        scanf("%s",mp[i]);
        for(int j=0;j<n;j++){
            if(mp[i][j]=='K'){
                stx=i;sty=j;
            }
            if(mp[i][j]=='S'){
                mp[i][j]=c++;
            }
        }
    }
    memset(vis,0,sizeof(vis));
    while(!que.empty())que.pop();
}
void solve(){
    que.push(node(stx,sty,0,0,0));
    while(!que.empty()){
        node tmp=que.top();
        que.pop();
        if(mp[tmp.x][tmp.y]=='T'&&tmp.key==k){
            printf("%d\n",tmp.time);
            return;
        }
        for(int i=0;i<4;i++){
            node newp=tmp;
            newp.x+=dx[i];
            newp.y+=dy[i];
            if(newp.x<0||newp.x>=n||newp.y<0||newp.y>=n||mp[newp.x][newp.y]=='#')continue;
            if(mp[newp.x][newp.y]>='a'&&mp[newp.x][newp.y]<='a'+5){///s
                int s=mp[newp.x][newp.y]-'a';
                s=1<<s;
                if(!(newp.s&s)){
                    newp.s|=s;
                    newp.time++;
                }
            }
            else if(mp[newp.x][newp.y]>='1'&&mp[newp.x][newp.y]<='9'){
                if(mp[newp.x][newp.y]-'1'==newp.key){
                    newp.key++;
                }
            }
            if(vis[newp.x][newp.y][newp.key][newp.s])continue;
            vis[newp.x][newp.y][newp.key][newp.s]=1;
            newp.time++;
            que.push(newp);
        }
    }
    printf("impossible\n");
}
int main()
{
    while(scanf("%d%d",&n,&k),n||k){
        init();
        solve();
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章