poj 1050 To the Max

To the Max
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 40812   Accepted: 21645

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle. 
As an example, the maximal sub-rectangle of the array: 

0 -2 -7 0 
9 2 -6 2 
-4 1 -4 1 
-1 8 0 -2 
is in the lower left corner: 

9 2 
-4 1 
-1 8 
and has a sum of 15. 

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2

Sample Output

15

Source


題意:找最大的子矩陣,使其中的每項和最大。

思路:預處理求每列的和,然後枚舉寬度爲n的所有矩陣做dp。

ps:明天有比賽,刷刷題練練手吧

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
const int N=105;
const int inf=0x3f3f3f3f;
int n,ans;
int a[N][N],sum[N][N],dp[N];
void init()
{
    memset(sum,0,sizeof(sum));
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
        for(int j=1;j<=n;j++){
            scanf("%d",&a[i][j]);
            sum[i][j]=sum[i-1][j]+a[i][j];
        }
}
void solve()
{
    for(int i=1;i<=n;i++){
        for(int j=i;j<=n;j++){
            dp[0]=-inf;
            for(int k=1;k<=n;k++){
                dp[k]=max(dp[k-1]+sum[j][k]-sum[i-1][k],sum[j][k]-sum[i-1][k]);
                ans=max(dp[k],ans);
            }
        }
    }
    printf("%d\n",ans);
}
int main()
{
    init();
    solve();
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章