POJ - 1007

Description

One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted). 

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length. 

Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.

Output

Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.

Sample Input

10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

Sample Output

CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA

TTTGGCCAAA

題解:找出各字符串中錯誤排序次數是多少,累計錯誤排序次數是利用反序累加,利用反序,就知道當前字符與後面字符是否大小排序,若不是就累加後面小於它的字符,所有字符串都累加錯誤次序後就按照error排序從小到大。第一次的時候WA是因爲沒看到如果錯誤次數相等就按照原來順序。。。然後改了cmp函數,讓a.error>=b.error就不會出現錯誤相同順序不同!

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <string>
using namespace std;
struct DNA{
    string str;
    int error;
};

int getError(string str){
    int sum = 0;
    int count[4] = {0,0,0,0};
    int len = str.length()-1;
    for(int i = len; i >=0 ;i--){
        char temp = str.at(i);
        switch(temp){
        case 'A':count[0]++;break;
        case 'C':count[1]++,sum=sum+count[0];break;
        case 'G':count[2]++,sum=sum+count[1]+count[0];break;
        case 'T':sum=sum+count[0]+count[1]+count[2];break;
        }
    }
    return sum;
}

bool cmp(DNA a,DNA b){
    return a.error>=b.error?false:true;
}

int main(){
    int n,m;
    cin>>n>>m;
    DNA d[105];
    for(int i = 0; i < m ;i++){
        string str;cin>>str;
        d[i].str = str;d[i].error = getError(str);
    }
    sort(d,d+m,cmp);
    for(int i = 0;i < m;i++){
        cout<<d[i].str<<endl;
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章