UVA - 1368 DNA Consensus String

\epsfbox{p3602.eps} Figure 1.
DNA (Deoxyribonucleic Acid) is the molecule which contains the genetic instructions. It consists of four different nucleotides, namely Adenine, Thymine, Guanine, and Cytosine as shown in Figure 1. If we represent a nucleotide by its initial character, a DNA strand can be regarded as a long string (sequence of characters) consisting of the four characters A, T, G, and C. For example, assume we are given some part of a DNA strand which is composed of the following sequence of nucleotides:


``Thymine-Adenine-Adenine-Cytosine-Thymine-Guanine-Cytosine-Cytosine-Guanine-Adenine-Thymine"


Then we can represent the above DNA strand with the string ``TAACTGCCGAT." The biologist Prof. Ahn found that a gene X commonly exists in the DNA strands of five different kinds of animals, namely dogs, cats, horses, cows, and monkeys. He also discovered that the DNA sequences of the gene X from each animal were very alike. See Figure 2.


  DNA sequence of gene X
Cat: GCATATGGCTGTGCA
Dog: GCAAATGGCTGTGCA
Horse: GCTAATGGGTGTCCA
Cow: GCAAATGGCTGTGCA
Monkey: GCAAATCGGTGAGCA


Figure 2. DNA sequences of gene X in five animals.


Prof. Ahn thought that humans might also have the gene X and decided to search for the DNA sequence of X in human DNA. However, before searching, he should define a representative DNA sequence of gene X because its sequences are not exactly the same in the DNA of the five animals. He decided to use the Hamming distance to define the representative sequence. The Hamming distance is the number of different characters at each position from two strings of equal length. For example, assume we are given the two strings ``AGCAT" and ``GGAAT." The Hamming distance of these two strings is 2 because the 1st and the 3rd characters of the two strings are different. Using the Hamming distance, we can define a representative string for a set of multiple strings of equal length. Given a set of strings S = s1,..., sm of length n , the consensus error between a string y of length n and the set S is the sum of the Hamming distances between y and each si in S . If the consensus error between y and S is the minimum among all possible strings y of length n , y is called a consensus string of S . For example, given the three strings `` AGCAT" `` AGACT" and `` GGAAT" the consensus string of the given strings is `` AGAAT" because the sum of the Hamming distances between `` AGAAT" and the three strings is 3 which is minimal. (In this case, the consensus string is unique, but in general, there can be more than one consensus string.) We use the consensus string as a representative of the DNA sequence. For the example of Figure 2 above, a consensus string of gene X is `` GCAAATGGCTGTGCA" and the consensus error is 7.

Input 

Your program is to read from standard input. The input consists of T test cases. The number of test cases T is given in the first line of the input. Each test case starts with a line containing two integers m and n which are separated by a single space. The integer m(4$ \le$m$ \le$50)represents the number of DNA sequences and n(4$ \le$n$ \le$1000) represents the length of the DNA sequences, respectively. In each of the nextm lines, each DNA sequence is given.

Output 

Your program is to write to standard output. Print the consensus string in the first line of each case and the consensus error in the second line of each case. If there exists more than one consensus string, print the lexicographically smallest consensus string. The following shows sample input and output for three test cases.

Sample Input 

3 
5 8 
TATGATAC 
TAAGCTAC 
AAAGATCC 
TGAGATAC 
TAAGATGT 
4 10 
ACGTACGTAC 
CCGTACGTAG 
GCGTACGTAT 
TCGTACGTAA 
6 10 
ATGTTACCAT 
AAGTTACGAT 
AACAAAGCAA 
AAGTTACCTT 
AAGTTACCAA 
TACTTACCAA

Sample Output 

TAAGATAC 
7 
ACGTACGTAA 
6 
AAGTTACCAA 

12

題解:要找出最小距離hamming字符串就是找出每一列重複最多的字符然後把它們連起來,就是最優解

#include <iostream>
#include <cstdio>
#include <cstring>
#include <map>
using namespace std;

int main(){
    int T;
    while(cin>>T){
        while(T--){
            int m,n;
            cin>>m>>n;
            cin.get();   //要吃掉一個回車鍵,如果沒有的話下面循環第一個gets會吃掉回車
            int error = 0;  //錯誤計數
            int maxn = 0;  //選擇出這一列最多是哪個字符
            int index = 0; //str字符串的底數
            char hamming[1005]; //hamming最小的字符串
            memset(hamming,0,sizeof(hamming));
            char dna[55][1005];
            for(int i = 0 ;i < m ;i++) gets(dna[i]);
            for(int i = 0; i < n; i++,index++){
                map<char,int> dna_map;
                for(int j = 0; j < m; j++) ++dna_map[dna[j][i]];//求出ATCG一列中各佔多少
                //循環找出某列中maxn最大的字符重複,加入到hamming中
                for(map<char,int>::const_iterator it = dna_map.begin();it!=dna_map.end();it++){
                    if(maxn < it->second)
                        maxn = it->second,hamming[index] = it->first;
                    error += it->second; // 把全部都加,在下面的error中減去maxn就是真正的error
                }
                error -= maxn;
                maxn = 0;
                dna_map.clear();
            }
            hamming[index] = '\0';
            printf("%s\n%d\n",hamming,error);
            error = 0;
        }
    }
    return 0;
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章