hdu1677 Nested Dolls(貪心)

Nested Dolls

http://acm.hdu.edu.cn/showproblem.php?pid=1677

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2286    Accepted Submission(s): 655


Problem Description
Dilworth is the world’s most prominent collector of Russian nested dolls: he literally has thousands of them! You know, the wooden hollow dolls of different sizes of which the smallest doll is contained in the second smallest, and this doll is in turn contained in the next one and so forth. One day he wonders if there is another way of nesting them so he will end up with fewer nested dolls? After all, that would make his collection even more magnificent! He unpacks each nested doll and measures the width and height of each contained doll. A doll with width w1 and height h1 will fit in another doll of width w2 and height h2 if and only if w1 < w2 and h1 < h2. Can you help him calculate the smallest number of nested dolls possible to assemble from his massive list of measurements?
 

Input
On the first line of input is a single positive integer 1 <= t <= 20 specifying the number of test cases to follow. Each test case begins with a positive integer 1 <= m <= 20000 on a line of itself telling the number of dolls in the test case. Next follow 2m positive integers w1, h1,w2, h2, . . . ,wm, hm, where wi is the width and hi is the height of doll number i. 1 <= wi, hi <= 10000 for all i.
 

Output
For each test case there should be one line of output containing the minimum number of nested dolls possible.
 

Sample Input
4 3 20 30 40 50 30 40 4 20 30 10 10 30 20 40 50 3 10 30 20 20 30 10 4 10 10 20 30 40 50 39 51
 

Sample Output
1 2 3 2
 

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct ss
{
    int w,h;
} s[20004],t[20004];
bool cmp(ss a,ss b)
{
    if(a.w==b.w) return a.h>b.h;//即使相等也不可套,既然要開闢新的一摞,不妨用較小的來開闢,再往上套的可能性會更大
    return a.w<b.w;
}
int main()
{
    int cas,n,i,j,ans;
    scanf("%d",&cas);
    while(cas--)
    {
    	memset(t,0,sizeof(t));
        scanf("%d",&n);
        for(i=0; i<n; i++)
            scanf("%d%d",&s[i].w,&s[i].h);
        sort(s,s+n,cmp);
        ans=0;
        for(i=0; i<n; i++)
        {
            j=0;
            while(s[i].w<=t[j].w||s[i].h<=t[j].h)
                j++;
            if(j>ans)
                ans=j;
            t[j]=s[i];
        }
        printf("%d\n",++ans);
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章