hdu1711 Number Sequence(KMP)

Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9536    Accepted Submission(s): 4362


Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 

Sample Input
2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
 

Sample Output
6 -1
 

KMP模板題  KMP算法詳解http://blog.csdn.net/cainiaoxiaojunjun/article/details/21326301

#include<stdio.h>
int s[1000004],t[10004],next[10004];
void get_nextval(int len)
{
    int i=0,k=-1;
    next[0]=-1;
    while(i<len)
        if(k==-1||t[i]==t[k])
        {
            ++i;
            ++k;
            if(t[i]!=t[k])
                next[i]=k;
            else
                next[i]=next[k];
        }
        else
            k=next[k];
}
int KMP(int ls,int lt)
{
    get_nextval(lt);
    int index=0,i=0,j=0;
    while(i<ls&&j<lt)
        if(s[i]==t[j])
        {
            i++;
            j++;
        }
        else
        {
            index+=j-next[j];
            if(next[j]!=-1)
                j=next[j];
            else
            {
                j=0;
                i++;
            }
        }
    if(j==lt) return index+1;
    else return -1;
}
int main()
{
	int cas,n,m,i,j;
    scanf("%d",&cas);
    while(cas--)
    {
        scanf("%d%d",&n,&m);
        for(i=0;i<n;i++)
			scanf("%d",&s[i]);
		for(j=0;j<m;j++)
			scanf("%d",&t[j]);
        int ans=KMP(n,m);
        printf("%d\n",ans);
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章