ZOJ Problem Set - 3946 Highway Project

Highway Project

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Edward, the emperor of the Marjar Empire, wants to build some bidirectional highways so that he can reach other cities from the capital as fast as possible. Thus, he proposed the highway project.

The Marjar Empire has N cities (including the capital), indexed from 0 to N - 1 (the capital is 0) and there are M highways can be built. Building the i-th highway costs Ci dollars. It takes Diminutes to travel between city Xi and Yi on the i-th highway.

Edward wants to find a construction plan with minimal total time needed to reach other cities from the capital, i.e. the sum of minimal time needed to travel from the capital to city i (1 ≤ i ≤ N). Among all feasible plans, Edward wants to select the plan with minimal cost. Please help him to finish this task.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first contains two integers NM (1 ≤ NM ≤ 105).

Then followed by M lines, each line contains four integers XiYiDiCi (0 ≤ XiYi < N, 0 < DiCi < 105).

Output

For each test case, output two integers indicating the minimal total time and the minimal cost for the highway project when the total time is minimized.

Sample Input

2
4 5
0 3 1 1
0 1 1 1
0 2 10 10
2 1 1 1
2 3 1 2
4 5
0 3 1 1
0 1 1 1
0 2 10 10
2 1 2 1
2 3 1 2

Sample Output

4 3
4 4

借鑑自:http://blog.csdn.net/u014445884/article/details/51232985



題意:

給你n個點,m條邊。每條邊有通過的時間花費,與修建該邊的金錢花費。問你所有點(1~n-1)到點0的距離之和最小時,所花最少錢爲多少。

分析:

dijkstra即可,根據距離和花費的要求不同優先級進行排序,求出答案。

看題的時候硬是沒看懂題意,先看成最小生成樹,後看成歐拉路反正就是個錯,這要是打現場賽也是爆炸,看了題解才懂,懵逼。


#include <algorithm>
#include <iostream>
#include <sstream>
#include <cstring>
#include <cstdlib>
#include <string>
#include <fstream>
#include <vector>
#include <cstdio>
#include <cmath>
#include <queue>
#include <stack>
#include <map>
#include <set>
using namespace std;
#define INF 0x3f3f3f3f
const int N=100005;
const int mod=1e9+7;

struct node {
    int x;
    long long d,c;
    node(int xx, long long dd, long long cc) {x=xx,d=dd,c=cc;}
    bool operator < (const node &p) const {
        return d>p.d;
    }
};

vector<node>  e[N];
priority_queue<node> q;
bool vis[N];
long long dis[N],cost[N];

void dij(int n) {
    for(int i=0;i<n;i++){
        dis[i]=1e12;
        cost[i]=1e12;
    }
    while (!q.empty()) q.pop();
    q.push(node(0, 0, 0));
    dis[0]=cost[0]=0;
    while (!q.empty()) {
        node p=q.top();
        q.pop();
        if (vis[p.x]) continue;
        vis[p.x]=1;
        for (int i=0; i<e[p.x].size(); i++) {
            node pp=e[p.x][i];
            int to=pp.x;
            long long dd=pp.d;
            if (dis[to]>dis[p.x]+dd) {
                dis[to]=dis[p.x]+dd;
                cost[to]=pp.c;
                q.push(node(to, dis[to], cost[to]));
            } else if (dis[to]==dis[p.x]+dd&&cost[to]>pp.c) {
                cost[to]=pp.c;
                q.push(node(to, dis[to], cost[to]));
            }
        }
    }
    long long ans1=0,ans2=0;
    for (int i=0; i<n; i++) {
        ans1+=dis[i];
        ans2+=cost[i];
    }
    cout<<ans1<<" "<<ans2<<endl;
}


int main() {
    int n,m,t;
    int x,y,d,c;
    cin>>t;
    while (t--) {
        cin>>n>>m;
        memset(e,0,(n+1)*sizeof e[0]);
        memset(vis, 0, sizeof(vis));
        
        for (int i=0; i<m; i++) {
            scanf("%d %d %d %d",&x,&y,&d,&c);
            e[y].push_back(node(x, d, c));
            e[x].push_back(node(y, d, c));
        }
        dij(n);
    }
    return 0;
}


給你n個點,m條邊。每條邊有通過的時間花費,與修建該邊的金錢花費。問你所有點(1~n-1)到點0的距離之和最小時,所花最少錢爲多少。

分析:

dijkstra即可,根據距離和花費的要求不同優先級進行排序,求出答案。

看題的時候硬是沒看懂題意,先看成最小生成樹,後看成歐拉路反正就是個錯,這要是打現場賽也是爆炸,看了題解才懂,懵逼。

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章