hdu 5305

Friends

Problem Description
There are n people and m pairs of friends. For every pair of friends, they can choose to become online friends (communicating using online applications) or offline friends (mostly using face-to-face communication). However, everyone in these n people wants to have the same number of online and offline friends (i.e. If one person has x onine friends, he or she must have x offline friends too, but different people can have different number of online or offline friends). Please determine how many ways there are to satisfy their requirements. 
 

Input
The first line of the input is a single integer T (T=100), indicating the number of testcases. 

For each testcase, the first line contains two integers n (1n8) and m (0mn(n1)2), indicating the number of people and the number of pairs of friends, respectively. Each of the next m lines contains two numbers x and y, which mean x and y are friends. It is guaranteed that xy and every friend relationship will appear at most once. 
 

Output
For each testcase, print one number indicating the answer.
 

Sample Input
2 3 3 1 2 2 3 3 1 4 4 1 2 2 3 3 4 4 1
 

Sample Output
0 2
 
 
dfs遍歷邊,入手點很重要。
代碼如下:
#include<stdio.h>
#include<iostream>
#include<string.h>
using namespace std;
int x[50],y[50],index[50],on[50],off[50],ans,m,n;
void dfs(int num)
{
    if(num==m+1){
        for(int i=1;i<=n;i++)
            if(on[i]!=off[i])
                return ;
        ans++;
        return ;
    }
    int a=x[num],b=y[num];
    if(on[a]<index[a]/2&&on[b]<index[b]/2){
        on[a]++;
        on[b]++;
        dfs(num+1);
        on[a]--;
        on[b]--;
    }
    if(off[a]<index[a]/2&&off[b]<index[b]/2){
        off[a]++;
        off[b]++;
        dfs(num+1);
        off[a]--;
        off[b]--;
    }
    return ;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--){
        scanf("%d%d",&n,&m);
        memset(index,0,sizeof(index));
        memset(on,0,sizeof(on));
        memset(off,0,sizeof(off));
        for(int i=1;i<=m;i++){
            scanf("%d%d",&x[i],&y[i]);
            index[x[i]]++;
            index[y[i]]++;
        }
        ans=0;
        dfs(1);
        printf("%d\n",ans);
    }
    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章