Dragon of Loowater

題目鏈接:http://hdu.hustoj.com/showproblem.php?pid=1902

題目:

Problem Description
Once upon a time, in the Kingdom of Loowater, a minor nuisance turned into a major problem.
The shores of Rellau Creek in central Loowater had always been a prime breeding ground for geese. Due to the lack of predators, the geese population was out of control. The people of Loowater mostly kept clear of the geese. Occasionally, a goose would attack one of the people, and perhaps bite off a finger or two, but in general, the people tolerated the geese as a minor nuisance.

One day, a freak mutation occurred, and one of the geese spawned a multi-headed fire-breathing dragon. When the dragon grew up, he threatened to burn the Kingdom of Loowater to a crisp. Loowater had a major problem. The king was alarmed, and called on his knights to slay the dragon and save the kingdom.

The knights explained: "To slay the dragon, we must chop off all its heads. Each knight can chop off one of the dragon's heads. The heads of the dragon are of different sizes. In order to chop off a head, a knight must be at least as tall as the diameter of the head. The knights' union demands that for chopping off a head, a knight must be paid a wage equal to one gold coin for each centimetre of the knight's height."

Would there be enough knights to defeat the dragon? The king called on his advisors to help him decide how many and which knights to hire. After having lost a lot of money building Mir Park, the king wanted to minimize the expense of slaying the dragon. As one of the advisors, your job was to help the king. You took it very seriously: if you failed, you and the whole kingdom would be burnt to a crisp!


Input
The input contains several test cases. The first line of each test case contains two integers between 1 and 20000 inclusive, indicating the number n of heads that the dragon has, and the number m of knights in the kingdom. The next n lines each contain an integer, and give the diameters of the dragon's heads, in centimetres. The following m lines each contain an integer, and specify the heights of the knights of Loowater, also in centimetres.
The last test case is followed by a line containing:
0 0


Output
For each test case, output a line containing the minimum number of gold coins that the king needs to pay to slay the dragon. If it is not possible for the knights of Loowater to slay the dragon, output the line:
Loowater is doomed!


Sample Input
2 3
5
4
7
8
4
2 1
5
5
10
0 0


Sample Output
11
Loowater is doomed!


大意:n個龍頭,m個騎士,一個騎士可以殺掉一個頭,但是騎士的身高必須大於等於龍頭的直徑,每個騎士殺掉一個頭的報酬是騎士的身高,問怎樣能花最少的錢


思路:將騎士的身高和龍頭的直徑分別排序,然後用貪心解決,具體看代碼


代碼:

<span style="font-size:18px;">#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
int head[20010];
int height[20010];
int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m) && n && m)
    {
        for(int i = 0; i< n; i++)
        {
            scanf("%d", &head[i]);
        }
        for(int i = 0; i< m; i++)
        {
            scanf("%d", &height[i]);
        }
        if(n > m)
        {
            printf("Loowater is doomed!\n");
            continue;
        }
        sort(head, head+n);
        sort(height, height+m);
        int cnt1 = 0 , cnt2 = 0;
        int cnt = 0 , sum = 0;
        while(cnt < n)
        {
            if(height[cnt1] >= head[cnt2])
            {
                sum += height[cnt1];
                cnt1++;
                cnt2++;
                cnt++;
            }
            else
                cnt1++;
            if(cnt1 > m)
            {
                break;
            }
        }
        if(cnt1 > m)
            printf("Loowater is doomed!\n");
        else
            printf("%d\n", sum);
    }
    return 0;
}</span>


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章