hdu 5.2.7 1053 Entropy

哎喲。。標題就看不懂這是鬧哪樣。。不如先來學習下單詞吧。。

entropy 熵
glyph 象形文字
prefix-free 無前綴

歐克,上題:

Entropy

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 71 Accepted Submission(s): 41
 
Problem Description
An entropy encoder is a data encoding method that achieves lossless data compression by encoding a message with “wasted” or “extra” information removed. In other words, entropy encoding removes information that was not necessary in the first place to accurately encode the message. A high degree of entropy implies a message with a great deal of wasted information; english text encoded in ASCII is an example of a message type that has very high entropy. Already compressed messages, such as JPEG graphics or ZIP archives, have very little entropy and do not benefit from further attempts at entropy encoding.

English text encoded in ASCII has a high degree of entropy because all characters are encoded using the same number of bits, eight. It is a known fact that the letters E, L, N, R, S and T occur at a considerably higher frequency than do most other letters in english text. If a way could be found to encode just these letters with four bits, then the new encoding would be smaller, would contain all the original information, and would have less entropy. ASCII uses a fixed number of bits for a reason, however: it’s easy, since one is always dealing with a fixed number of bits to represent each possible glyph or character. How would an encoding scheme that used four bits for the above letters be able to distinguish between the four-bit codes and eight-bit codes? This seemingly difficult problem is solved using what is known as a “prefix-free variable-length” encoding.

In such an encoding, any number of bits can be used to represent any glyph, and glyphs not present in the message are simply not encoded. However, in order to be able to recover the information, no bit pattern that encodes a glyph is allowed to be the prefix of any other encoding bit pattern. This allows the encoded bitstream to be read bit by bit, and whenever a set of bits is encountered that represents a glyph, that glyph can be decoded. If the prefix-free constraint was not enforced, then such a decoding would be impossible.

Consider the text “AAAAABCD”. Using ASCII, encoding this would require 64 bits. If, instead, we encode “A” with the bit pattern “00”, “B” with “01”, “C” with “10”, and “D” with “11” then we can encode this text in only 16 bits; the resulting bit pattern would be “0000000000011011”. This is still a fixed-length encoding, however; we’re using two bits per glyph instead of eight. Since the glyph “A” occurs with greater frequency, could we do better by encoding it with fewer bits? In fact we can, but in order to maintain a prefix-free encoding, some of the other bit patterns will become longer than two bits. An optimal encoding is to encode “A” with “0”, “B” with “10”, “C” with “110”, and “D” with “111”. (This is clearly not the only optimal encoding, as it is obvious that the encodings for B, C and D could be interchanged freely for any given encoding without increasing the size of the final encoded message.) Using this encoding, the message encodes in only 13 bits to “0000010110111”, a compression ratio of 4.9 to 1 (that is, each bit in the final encoded message represents as much information as did 4.9 bits in the original encoding). Read through this bit pattern from left to right and you’ll see that the prefix-free encoding makes it simple to decode this into the original text even though the codes have varying bit lengths.

As a second example, consider the text “THE CAT IN THE HAT”. In this text, the letter “T” and the space character both occur with the highest frequency, so they will clearly have the shortest encoding bit patterns in an optimal encoding. The letters “C”, “I’ and “N” only occur once, however, so they will have the longest codes.

There are many possible sets of prefix-free variable-length bit patterns that would yield the optimal encoding, that is, that would allow the text to be encoded in the fewest number of bits. One such optimal encoding is to encode spaces with “00”, “A” with “100”, “C” with “1110”, “E” with “1111”, “H” with “110”, “I” with “1010”, “N” with “1011” and “T” with “01”. The optimal encoding therefore requires only 51 bits compared to the 144 that would be necessary to encode the message with 8-bit ASCII encoding, a compression ratio of 2.8 to 1.
 
Input
The input file will contain a list of text strings, one per line. The text strings will consist only of uppercase alphanumeric characters and underscores (which are used in place of spaces). The end of the input will be signalled by a line containing only the word “END” as the text string. This line should not be processed.
 
Output

            For each text string in the input, output the length in bits of the 8-bit ASCII encoding, the length in bits of an optimal prefix-free variable-length encoding, and the compression ratio accurate to one decimal point.
 
Sample Input
AAAAABCD
THE_CAT_IN_THE_HAT
END
 
Sample Output
64 13 4.9
144 51 2.8
 

依舊是樸素的哈夫曼。長長的題目就是讓我知道了具體哈夫曼的應用。。

別處拷貝來的中文說明:

假設有一段電文,其中用到 4 個不同字符A, C, S, T,它們在電文中出現的次數分別爲 8 , 2 , 4 , 5 。把 8, 2 , 4 , 5 當做 4 個葉子的權值構造哈夫曼樹如下圖所示。在樹中令所有左分支取編碼爲 0 ,令所有右分支取編碼爲1。將從根結點起到某個葉子結點路徑上的各左、右分支的編碼順序排列,就得這個葉子結點所代表的字符的二進制編碼,j結果如下圖所示。

這些編碼拼成的電文不會混淆,因爲每個字符的編碼均不是其他編碼的前綴,這種編碼稱做前綴編碼。關於信息編碼是一個複雜的問題,還應考慮其他一些因素。比如前綴編碼每個編碼的長度不相等,譯碼時較困難。還有檢測、糾錯問題都應考慮在內。這裏僅對哈夫曼樹舉了一個應用實例。

真是很有趣啊……到底是怎麼想到這麼神奇的東西的呢?

試了一下通過回憶(喂!)自己打了一遍哈夫曼的構造。瞄了前一題兩次,無編譯錯(之前題抄還抄錯兩次- -),一次通過,還挺開心的~

和前題幾乎一樣的代碼- -。。。

#include <iostream>
#include <cstring>
#include <string>
using namespace std;

struct{
       int weight;
       int parent;
       int left;
       int right;
       }node[60];



int main()
{
    char ch[100000];
    int hash[35];
    int i,j,k;
    int len;
    while(cin>>ch,strcmp(ch,"END")!=0)
    {
        memset(hash,0,sizeof(hash));
        len=strlen(ch);
        for(i=0;i<len;i++)
        {
            hash[ch[i]-64]++;
        }
        for(i=1,j=1;i<35;i++)
        {
            if(hash[i]!=0)
            {
                node[j].weight=hash[i];
                node[j].parent=node[j].left=node[j].right=0;
                j++;
            }
        }
        
        j--;
        
        for(i=j+1;i<j*2;i++)
            node[i].parent=node[i].left=node[i].right=0;
        
        for(i=j+1;i<j*2;i++)
        {
            int m1,m2;
            m1=m2=999999;
            int x1,x2;
            for(k=1;k<i;k++)
            {
                if(node[k].weight<m1&&node[k].parent==0)
                {
                    m2=m1;
                    x2=x1;
                    m1=node[k].weight;
                    x1=k;
                }
                else if(node[k].weight<m2&&node[k].parent==0)
                {
                    m2=node[k].weight;
                    x2=k;
                }
            }
            node[i].weight=m1+m2;
            node[i].right=x1;
            node[i].left=x2;
            node[x1].parent=i;
            node[x2].parent=i;
        }
        
        int sum=0;
        int cnt;
        for(i=1;i<j+1;i++)
        {
            k=i;
            cnt=0;
            while(node[k].parent!=0)
            {
                k=node[k].parent;
                cnt++;
            }
            sum+=cnt*node[i].weight;
        }
        if(j==1)
            sum=len;
        float ratio;
        ratio=float(len*8)/sum;
        printf("%d %d %.1f\n",len*8,sum,ratio);
    }
    return 0;
}
        
            

小困惑是。。cout沒法兒規範小數點後幾位麼?不得不用printf了。。。不過printf用起來確實比cout舒服。。。

過年了。奇怪的大年二十九。新的一年要努力。要保持好的心態。要相信自己會變好看,會碼代碼,會贏得妹子芳心的。無論發生什麼都不要自虐了,如果不開心寧可去騷擾妹子吧。雖然可能會被煩……不過無節操這麼久了,隨意吧。會好好的。即使是末日,也要好好的度過之前的每一天。平凡的快樂的充實的每一天。

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章