hdu_1710_Binary Tree Traversals(二叉樹的重構)

Description

A binary tree is a finite set of vertices that is either empty or consists of a root r and two disjoint binary trees called the left and right subtrees. There are three most important ways in which the vertices of a binary tree can be systematically traversed or ordered. They are preorder, inorder and postorder. Let T be a binary tree with root r and subtrees T1,T2.

In a preorder traversal of the vertices of T, we visit the root r followed by visiting the vertices of T1 in preorder, then the vertices of T2 in preorder.

In an inorder traversal of the vertices of T, we visit the vertices of T1 in inorder, then the root r, followed by the vertices of T2 in inorder.

In a postorder traversal of the vertices of T, we visit the vertices of T1 in postorder, then the vertices of T2 in postorder and finally we visit r.

Now you are given the preorder sequence and inorder sequence of a certain binary tree. Try to find out its postorder sequence.

Input

The input contains several test cases. The first line of each test case contains a single integer n (1<=n<=1000), the number of vertices of the binary tree. Followed by two lines, respectively indicating the preorder sequence and inorder sequence. You can assume they are always correspond to a exclusive binary tree.

Output

For each test case print a single line specifying the corresponding postorder sequence.

Sample Input

9
1 2 4 7 3 5 8 9 6
4 7 2 1 8 5 9 3 6

Sample Output

7 4 2 8 9 5 6 3 1

根據前序與中序遍歷結果輸出後序結果。

代碼

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

int pre[1005],in[1005];
int post[1005];
int flag;
void CreateTree(int preL,int preR,int inL,int inR)
{
    int i;
    int l;
    int r;
    if(preL <= preR && inL <= inR)
    {
        for(i=inL;i<inR;i++)  //根據中序排列確定左右子樹
        {
            if(pre[preL] == in[i])   //前序左邊第一個是根節點,在中序以根節點爲分界線分爲左右子樹
                break;
        }
        l = i-inL;  //左子樹的個數
        r = inR-i;  //右子樹的個數
        if(l > 0)
            CreateTree(preL+1,preL+l,inL,i-1);
        if( r > 0)
            CreateTree(preL+l+1,preR,i+1,inR);


        //printf("%d ",pre[preL]);//後續結果存到前序數組裏了
        if(flag == 1)  //用flag 的意義在於格式問題
        {
            printf("%d",pre[preL]);
            flag = 0;
        }
        else
            printf(" %d",pre[preL]);
    }
}
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        flag = 1;
        for(int i=0;i<n;i++)
            scanf("%d",&pre[i]);
        for(int i=0;i<n;i++)
            scanf("%d",&in[i]);
        CreateTree(0,n-1,0,n-1);
        printf("\n");
    }
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章