Python HackerRank|Lists

  1. Dashboard 
  2.  Python 
  3.  Basic Data Types 
  4.  Lists
    1. Consider a list (list = []). You can perform the following commands:

      1. insert i e: Insert integer  at position .
      2. print: Print the list.
      3. remove e: Delete the first occurrence of integer .
      4. append e: Insert integer  at the end of the list.
      5. sort: Sort the list.
      6. pop: Pop the last element from the list.
      7. reverse: Reverse the list.

      Initialize your list and read in the value of  followed by  lines of commands where each command will be of the types listed above. Iterate through each command in order and perform the corresponding operation on your list.

      Input Format

      The first line contains an integer, , denoting the number of commands. 
      Each line  of the  subsequent lines contains one of the commands described above.

      Constraints

      • The elements added to the list must be integers.

      Output Format

      For each command of type print, print the list on a new line.

      Sample Input

      12
      insert 0 5
      insert 1 10
      insert 0 6
      print 
      remove 6
      append 9
      append 1
      sort 
      print
      pop
      reverse
      print
      

      Sample Output

      [6, 5, 10]
      [1, 5, 9, 10]
      [9, 5, 1]

      1. if __name__ == '__main__':
            N = int(input())
            L = []
            for _ in range(N):
                s = input().split()
                dem = s[0]
                args = s[1:]
                if dem != 'print':
                    eval('L.' + dem + '(' + ', '.join(args) + ')')
                else:
                    print(L)


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章