HDU5113 Black And White【DFS】

Black And White

Time Limit: 2000/2000 MS (Java/Others) Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 7121 Accepted Submission(s): 1907
Special Judge

Problem Description
In mathematics, the four color theorem, or the four color map theorem, states that, given any separation of a plane into contiguous regions, producing a figure called a map, no more than four colors are required to color the regions of the map so that no two adjacent regions have the same color.
— Wikipedia, the free encyclopedia

In this problem, you have to solve the 4-color problem. Hey, I’m just joking.

You are asked to solve a similar problem:

Color an N × M chessboard with K colors numbered from 1 to K such that no two adjacent cells have the same color (two cells are adjacent if they share an edge). The i-th color should be used in exactly ci cells.

Matt hopes you can tell him a possible coloring.

Input
The first line contains only one integer T (1 ≤ T ≤ 5000), which indicates the number of test cases.

For each test case, the first line contains three integers: N, M, K (0 < N, M ≤ 5, 0 < K ≤ N × M ).

The second line contains K integers ci (ci > 0), denoting the number of cells where the i-th color should be used.

It’s guaranteed that c1 + c2 + · · · + cK = N × M .

Output
For each test case, the first line contains “Case #x:”, where x is the case number (starting from 1).

In the second line, output “NO” if there is no coloring satisfying the requirements. Otherwise, output “YES” in one line. Each of the following N lines contains M numbers seperated by single whitespace, denoting the color of the cells.

If there are multiple solutions, output any of them.

Sample Input
4
1 5 2
4 1
3 3 4
1 2 2 4
2 3 3
2 2 2
3 2 3
2 2 2

Sample Output
Case #1:
NO
Case #2:
YES
4 3 4
2 1 2
4 3 4
Case #3:
YES
1 2 3
2 3 1
Case #4:
YES
1 2
2 3
3 1

Source
2014ACM/ICPC亞洲區北京站-重現賽(感謝北師和上交)

問題鏈接HDU5113 Black And White
問題簡述:給定一個n*m的網格,有k種顏色,每種顏色有ci瓶,需要將相鄰的網格塗成不同顏色,並且需要將所有顏料用完。計算一下是否有可行方案。
問題分析
    用DFS實現,實際上是窮舉法,但是需要根據條件進行剪枝,否則時間上會有問題。
    剪枝條件是當未塗色格子總數+1小於某種顏色可以用的數量一半時,這種情況就不可能做到相鄰網格使用不同顏色。
程序說明:(略)
參考鏈接:(略)
題記:使用DFS解決問題時,如果能進行剪枝則要剪枝。

AC的C++語言程序如下:

/* HDU5113 Black And White */

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

const int N = 5;
int n, m, k, color[N * N + 1], b[N + 1][N + 1];
bool flag;

void dfs(int x, int y, int cnt)
{
    if(cnt==0) {flag=true; return;}
    for(int i=1; i<=k; i++)
        if((cnt + 1) / 2 < color[i]) return;

    for(int i = 1; i <= k; i++) {
        if(color[i] && b[x - 1][y] != i && b[x][y - 1] != i) {
            b[x][y] = i;
            color[i]--;
            int nx, ny;
            if(y + 1 > m)
                nx = x + 1, ny = 1;
            else
                nx = x, ny = y + 1;

            dfs(nx, ny, cnt - 1);
            if(flag) return;
            b[x][y] = 0;
            color[i]++;
        }
    }
    return;
}

int main()
{
    int t, caseno = 0;
    scanf("%d", &t);
    while(t--) {
        memset(b, 0, sizeof(b));

        printf("Case #%d:\n", ++caseno);

        scanf("%d%d%d", &n, &m, &k);
        for(int i = 1; i <= k; i++)
            scanf("%d", &color[i]);

        flag = false;
        dfs(1, 1, n * m);

        if(flag) {
            printf("YES\n");
            for(int i = 1; i <= n; i++) {
                for(int j = 1; j <= m; j++){
                    if(j != 1) printf(" ");
                    printf("%d", b[i][j]);
                }
                printf("\n");
            }
        } else
            printf("NO\n");
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章