Smith Numbers (POJ-1142)(素數判定+整數分解)

While skimming his phone directory in 1982, Albert Wilansky, a mathematician of Lehigh University,noticed that the telephone number of his brother-in-law H. Smith had the following peculiar property: The sum of the digits of that number was equal to the sum of the digits of the prime factors of that number. Got it? Smith's telephone number was 493-7775. This number can be written as the product of its prime factors in the following way:

4937775= 3*5*5*65837


The sum of all digits of the telephone number is 4+9+3+7+7+7+5= 42,and the sum of the digits of its prime factors is equally 3+5+5+6+5+8+3+7=42. Wilansky was so amazed by his discovery that he named this kind of numbers after his brother-in-law: Smith numbers.
As this observation is also true for every prime number, Wilansky decided later that a (simple and unsophisticated) prime number is not worth being a Smith number, so he excluded them from the definition.
Wilansky published an article about Smith numbers in the Two Year College Mathematics Journal and was able to present a whole collection of different Smith numbers: For example, 9985 is a Smith number and so is 6036. However,Wilansky was not able to find a Smith number that was larger than the telephone number of his brother-in-law. It is your task to find Smith numbers that are larger than 4937775!

Input

The input file consists of a sequence of positive integers, one integer per line. Each integer will have at most 8 digits. The input is terminated by a line containing the number 0.

Output

For every number n > 0 in the input, you are to compute the smallest Smith number which is larger than n,and print it on a line by itself. You can assume that such a number exists.

Sample Input

4937774
0

Sample Output

4937775

題意:找一個大於當前給出數的數(例如4937774),其每位數和( 4+9+3+7+7+7+5= 42)與其拆解成素數積(3*5*5*65837)後,每個素數每一位的和(3+5+5+6+5+8+3+7=42)相等。

思路:這道題的話,首先我們要找到這個數,這個數可以分解,所以它不能是素數,所以我們先判斷一下是否爲素數,然後我們先求所給數的每一位的和,再將所給數拆解爲素數積並求出每位和。最後判斷兩個是否相等,相等就是我們要找的數,不相等就繼續找。

AC代碼:

#include <stdio.h>
#include <string>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <math.h>
#include <queue>
#include <stack>
#include <map>
#include <set>
typedef long long ll;
const int maxx=100010;
const int inf=0x3f3f3f3f;
const double eps=1e-5;
using namespace std;
int isprime(int n)//判斷n是否爲素數
{
    for(int i=2; i*i<=n; i++)
        if(n%i==0)
            return 0;
    return 1;
}
int sum1(int n)//求n每一位的和
{
    int ans=0;
    while(n)
    {
        ans+=n%10;
        n/=10;
    }
    return ans;
}
int sum2(int n)//將n拆解爲素數積並求出每位和
{
    if(isprime(n))
        return sum1(n);
    for(int i=2; i*i<=n; i++)
    {
        if(n%i==0)
            return sum2(i)+sum2(n/i);
    }
}
int main()
{
    int n;
    while(~scanf("%d",&n),n)
    {
        int m=n;
        while(++m)
        {
            if(isprime(m))
                continue;
            int a=sum1(m);
            int b=sum2(m);
            if(a==b)
            {
                printf("%d\n",m);
                break;
            }
        }
    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章