Halloween treats (POJ-3370)(抽屜原理)

Every year there is the same problem at Halloween: Each neighbour is only willing to give a certain total number of sweets on that day, no matter how many children call on him, so it may happen that a child will get nothing if it is too late. To avoid conflicts, the children have decided they will put all sweets together and then divide them evenly among themselves. From last year's experience of Halloween they know how many sweets they get from each neighbour. Since they care more about justice than about the number of sweets they get, they want to select a subset of the neighbours to visit, so that in sharing every child receives the same number of sweets. They will not be satisfied if they have any sweets left which cannot be divided.

Your job is to help the children and present a solution.

Input

The input contains several test cases.
The first line of each test case contains two integers c and n (1 ≤ c ≤ n ≤ 100000), the number of children and the number of neighbours, respectively. The next line contains n space separated integers a1 , ... , an (1 ≤ ai ≤ 100000 ), where ai represents the number of sweets the children get if they visit neighbour i.

The last test case is followed by two zeros.

Output

For each test case output one line with the indices of the neighbours the children should select (here, index i corresponds to neighbour i who gives a total number of ai sweets). If there is no solution where each child gets at least one sweet print "no sweets" instead. Note that if there are several solutions where each child gets at least one sweet, you may print any of them.

Sample Input

4 5
1 2 3 7 5
3 6
7 11 2 5 13 17
0 0

Sample Output

3 5
2 3 4

題意:給出n和m及m個整數(n<m),要從m中找出任意個數使得其和是n的倍數,輸出時就輸出每一個數所在的編號。

思路:這道題的話,和poj-2356基本一樣,看詳解的話,看這裏:https://blog.csdn.net/weixin_43846139/article/details/105636991

AC代碼:

#include <stdio.h>
#include <string>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <math.h>
#include <queue>
#include <stack>
#include <map>
#include <set>
typedef long long ll;
const int maxx=100010;
const int inf=0x3f3f3f3f;
const double eps=1e-5;
using namespace std;
int a[maxx];
int mod[maxx];//mod[i]記錄sum[i]%n是否出現過,如果以出現,則標記爲出現的初始位置
int main()
{
    int c,n;
    while(~scanf("%d%d",&c,&n),c,n)
    {
        ll sum=0;
        for(int i=0; i<n; i++)
        {
            scanf("%d",&a[i]);
            mod[i]=-2;
        }
        mod[0]=-1;//mod[0]爲-1,就是假設存在a[-1],且a[-1]是n的倍數,這樣就可以把兩種情況寫在一起
        for(int i=0; i<n; i++)
        {
            sum+=a[i];
            if(mod[sum%c]!=-2)
            {//如果在i之前有與sum對n同餘的數,則可以輸出答案
                for(int j=mod[sum%c]+1; j<=i; j++)
                {
                    printf("%d",j+1);
                    if(i!=j)
                        printf(" ");
                }
                printf("\n");
                break;
            }
            mod[sum%c]=i;//將此時對應的餘數存到mod中,值爲此時的i
        }
    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章