E - E.龍皇異次元 (POJ-3723)(最大生成樹)

Windy has a country, and he wants to build an army to protect his country. He has picked up N girls and M boys and wants to collect them to be his soldiers. To collect a soldier without any privilege, he must pay 10000 RMB. There are some relationships between girls and boys and Windy can use these relationships to reduce his cost. If girl x and boy y have a relationship d and one of them has been collected, Windy can collect the other one with 10000-d RMB. Now given all the relationships between girls and boys, your assignment is to find the least amount of money Windy has to pay. Notice that only one relationship can be used when collecting one soldier.

Input

The first line of input is the number of test case.
The first line of each test case contains three integers, NM and R.
Then R lines followed, each contains three integers xiyi and di.
There is a blank line before each test case.

1 ≤ NM ≤ 10000
0 ≤ R ≤ 50,000
0 ≤ xi < N
0 ≤ yi < M
0 < di < 10000

Output

For each test case output the answer in a single line.

Sample Input

2

5 5 8
4 3 6831
1 3 4583
0 0 6592
0 1 3063
3 3 4975
1 3 2049
4 2 2104
2 2 781

5 5 10
2 4 9820
3 2 6236
3 1 8864
2 4 8326
2 0 5156
2 0 1463
4 1 2439
0 4 4373
3 4 8889
2 4 3133

Sample Output

71071
54223

題意:現在要徵n個男兵和m個女兵,每個花費10000元,但是如果已經徵募的男士兵中有和將要徵募的女士兵關係好的,那麼可以減少花費,給出關係,求最小花費。

思路:這道題的話,初始時候每個人花費是10000元,但如果有關係的話,就可以減去這個關係費。因爲我們求的是最小的花費,所以減去的最大即可,又因爲每個人只徵募一次,即最多選擇一個,所以將男生人數和女生人數加在一起乘以10000再減去一個最大生成樹即可。

AC代碼:

#include <stdio.h>
#include <string>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <math.h>
#include <queue>
#include <stack>
#include <map>
#include <set>
typedef long long ll;
const int maxx=50010;
const int mod=10007;
const int inf=0x3f3f3f3f;
const double eps=1e-8;
using namespace std;
int pre[maxx];
struct node
{
    int u;
    int v;
    int w;
} edge[maxx];
bool cmp(node x,node y)
{
    return x.w>y.w;
}
int getf(int x)
{
    if(x==pre[x])
        return pre[x];
    return pre[x]=getf(pre[x]);
}
int Kruskal(int x,int y)
{
    int ans=0;
    for(int i=0; i<x; i++)
        pre[i]=i;
    sort(edge,edge+y,cmp);
    for(int i=0; i<y; i++)
    {
        int fx=getf(edge[i].u);
        int fy=getf(edge[i].v);
        if(fx!=fy)
        {
            ans+=edge[i].w;
            pre[fy]=fx;
        }
    }
    return ans;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,m,r;
        scanf("%d%d%d",&n,&m,&r);
        for(int i=0; i<r; i++)
        {
            int x;
            scanf("%d%d%d",&edge[i].u,&edge[i].v,&edge[i].w);
            edge[i].v+=n;
        }
        int ans=Kruskal(m+n,r);
        printf("%d\n",(n+m)*10000-ans);
    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章