1111 Online Map (30分) [Dijkstra]

Input our current position and a destination, an online map can recommend several paths. Now your job is to recommend two paths to your user: one is the shortest, and the other is the fastest. It is guaranteed that a path exists for any request.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (2≤N≤500), and M, being the total number of streets intersections on a map, and the number of streets, respectively. Then M lines follow, each describes a street in the format:

V1 V2 one-way length time

where V1 and V2 are the indices (from 0 to N−1) of the two ends of the street; one-way is 1 if the street is one-way from V1 to V2, or 0 if not; length is the length of the street; and time is the time taken to pass the street.

Finally a pair of source and destination is given.

Output Specification:

For each case, first print the shortest path from the source to the destination with distance D in the format:

Distance = D: source -> v1 -> ... -> destination

Then in the next line print the fastest path with total time T:

Time = T: source -> w1 -> ... -> destination

In case the shortest path is not unique, output the fastest one among the shortest paths, which is guaranteed to be unique. In case the fastest path is not unique, output the one that passes through the fewest intersections, which is guaranteed to be unique.

In case the shortest and the fastest paths are identical, print them in one line in the format:

Distance = D; Time = T: source -> u1 -> ... -> destination

Sample Input 1:

10 15
0 1 0 1 1
8 0 0 1 1
4 8 1 1 1
3 4 0 3 2
3 9 1 4 1
0 6 0 1 1
7 5 1 2 1
8 5 1 2 1
2 3 0 2 2
2 1 1 1 1
1 3 0 3 1
1 4 0 1 1
9 7 1 3 1
5 1 0 5 2
6 5 1 1 2
3 5

Sample Output 1:

Distance = 6: 3 -> 4 -> 8 -> 5
Time = 3: 3 -> 1 -> 5

Sample Input 2:

7 9
0 4 1 1 1
1 6 1 1 3
2 6 1 1 1
2 5 1 2 2
3 0 0 1 1
3 1 1 1 3
3 2 1 1 2
4 5 0 2 2
6 5 1 1 2
3 5

Sample Output 2:

Distance = 3; Time = 4: 3 -> 2 -> 5

題解:

直接兩遍迪傑斯特拉 over

#include <iostream>
#include <cstring>
#include <vector>

using namespace std;

const int N = 510;

int n, m, start, target;
int d[N][N], d2[N][N], dist[N], dist2[N], cost[N], pred[N], pret[N], cnt[N];
bool st[N];

void Dijkstra1() {
	memset(dist, 0x3f, sizeof(dist));
	dist[start] = 0;

	for (int i = 0; i < n; i++)
	{
		int t = -1;
		for (int j = 0; j < n; j++)
			if (!st[j] && (t == -1 || dist[j] < dist[t]))
				t = j;
		st[t] = true;

		for (int j = 0; j < n; j++)
		{
			if (dist[j] > dist[t] + d[t][j])
			{
				dist[j] = dist[t] + d[t][j];
				cost[j] = cost[t] + d2[t][j];
				pred[j] = t;
			}
			else if (dist[j] == dist[t] + d[t][j])
			{
				if (cost[j] > cost[t] + d2[t][j])
				{
					cost[j] = cost[t] + d2[t][j];
					pred[j] = t;
				}
			}
		}
	}
}
void Dijkstra2() {
	memset(dist2, 0x3f, sizeof(dist2));
	memset(st, false, sizeof(st));
	dist2[start] = 0;
	cnt[start] = 1;
	for (int i = 0; i < n; i++)
	{
		int t = -1;
		for (int j = 0; j < n; j++)
			if (!st[j] && (t == -1 || dist2[j] < dist2[t]))
				t = j;
		st[t] = true;

		for (int j = 0; j < n; j++)
		{
			if (dist2[j] > dist2[t] + d2[t][j])
			{
				dist2[j] = dist2[t] + d2[t][j];
				cnt[j] = cnt[t] + 1;
				pret[j] = t;
			}
			else if (dist2[j] == dist2[t] + d2[t][j])
			{
				if (cnt[j] > cnt[t] + 1)
				{
					cnt[j] = cnt[t] + 1;
					pret[j] = t;
				}
			}
		}
	}
}

int main() {

	cin >> n >> m;

	memset(d, 0x3f, sizeof(d));
	memset(d2, 0x3f, sizeof(d2));

	for (int i = 0; i < m; i++)
	{
		int v1, v2, oneway, l, t;
		cin >> v1 >> v2 >> oneway >> l >> t;
		if (oneway == 1) {
			d[v1][v2] = l;
			d2[v1][v2] = t;
		}
		else
		{
			d[v1][v2] = d[v2][v1] = l;
			d2[v1][v2] = d2[v2][v1] = t;
		}
	}
	cin >> start >> target;

	Dijkstra1();
	Dijkstra2();
	vector<int> pd, pt;
	for (int i = target; i != start; i = pred[i]) pd.push_back(i);
	for (int i = target; i != start; i = pret[i]) pt.push_back(i);

	if (pd == pt)
	{
		printf("Distance = %d; Time = %d: %d", dist[target], dist2[target], start);
		for (int i = pd.size() - 1; i >= 0; i--)
			printf(" -> %d", pd[i]);
	}
	else
	{
		printf("Distance = %d: %d", dist[target], start);
		for (int i = pd.size() - 1; i >= 0; i--)
			printf(" -> %d", pd[i]);
		cout << endl;
		printf("Time = %d: %d", dist2[target], start);
		for (int i = pt.size() - 1; i >= 0; i--)
			printf(" -> %d", pt[i]);
	}
	return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章